Last Comment Bug 740615 - Move rule view copy code into CssRuleView.jsm
: Move rule view copy code into CssRuleView.jsm
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: 13 Branch
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Dave Camp (:dcamp)
:
Mentors:
Depends on:
Blocks: 707809
  Show dependency treegraph
 
Reported: 2012-03-29 14:52 PDT by Dave Camp (:dcamp)
Modified: 2012-04-05 02:55 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
move the event handling to CssRuleView.jsm (30.89 KB, patch)
2012-03-29 14:54 PDT, Dave Camp (:dcamp)
paul: review+
mratcliffe: feedback+
Details | Diff | Review
typo fix (30.96 KB, patch)
2012-04-02 10:49 PDT, Dave Camp (:dcamp)
no flags Details | Diff | Review

Description Dave Camp (:dcamp) 2012-03-29 14:52:47 PDT
... because that's where it belongs.
Comment 1 Dave Camp (:dcamp) 2012-03-29 14:54:27 PDT
Created attachment 610708 [details] [diff] [review]
move the event handling to CssRuleView.jsm

There's no sense keeping all the event handling for the rule view anywhere but CssRuleView.jsm.  This is needed for the sidebar creation refactoring that's underway.
Comment 2 Michael Ratcliffe [:miker] [:mratcliffe] 2012-03-30 02:00:36 PDT
Comment on attachment 610708 [details] [diff] [review]
move the event handling to CssRuleView.jsm

Looks good to me. At some point we should also separate the shared stylesheets, DTD & properties files. The localizers have complained about duplicate strings even though they are used in 2 different tools.
Comment 3 Paul Rouget [:paul] 2012-03-30 09:40:45 PDT
Comment on attachment 610708 [details] [diff] [review]
move the event handling to CssRuleView.jsm

Review of attachment 610708 [details] [diff] [review]:
-----------------------------------------------------------------

r+, just a nit.

::: browser/devtools/styleinspector/CssRuleView.jsm
@@ +738,5 @@
> +    delete this._boundCopyProperty;
> +
> +    this._propertyValueItem.removeEventListener("command", this._boundCopyPropertyValue);
> +    delete this._boundCopyProperrtyValue;
> +

_boundCopyProperrtyValue <- extra 'r'
Comment 4 Dave Camp (:dcamp) 2012-04-02 10:49:19 PDT
Created attachment 611519 [details] [diff] [review]
typo fix
Comment 6 Tim Taubert [:ttaubert] 2012-04-05 02:55:19 PDT
https://hg.mozilla.org/mozilla-central/rev/f47780831b31

Note You need to log in before you can comment on or make changes to this bug.