Remove sound from SWF/FLV files hosted on mozqa.com

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
7 years ago
5 months ago

People

(Reporter: whimboo, Assigned: ashughes)

Tracking

Details

(Whiteboard: [mozmill-endurance], URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

7 years ago
It's getting a major pain when running Mozmill Endurance tests and having the box playing the sound. The SWF/FLV files produced by Rainer last year should be updated to no longer contain sound.

Rainer, would you mind helping us here? The files I'm talking about can be found here: http://mozqa.com/data/firefox/plugins/flash/. All the sample files will have to be checked.

Thanks!
I second Henrik's opinion. I always mute all speakers/sound when running endurance tests locally
(Assignee)

Comment 2

7 years ago
Is there any way to do this without getting Rainer to create new videos?
Whiteboard: [mozmill-endurance]
(Reporter)

Comment 3

7 years ago
I don't think that he has to create new videos. Hopefully the audio track can simply be demuxed? Sounds like http://www.sothink.com/product/flashdecompiler/index.htm could be a quick option for us to do it on our own.
(Assignee)

Comment 4

7 years ago
I chatted with Rainer today via email and he told me he can probably get me something tomorrow.

Note: I'm proposing we don't replace the current videos, but add two copies of the 10s video with sound removed. This will give us 10s videos with and without sound, should we need to test either.
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #4)
> Note: I'm proposing we don't replace the current videos, but add two copies
> of the 10s video with sound removed. This will give us 10s videos with and
> without sound, should we need to test either.
If we keep these files and add soundless copies, we need to edit the tests in order to use the soundless files. I propose we rename the existing files, adding a -sound in the name, and have the soundless files have the exact same name the current files have now. This way we don't need to edit our tests, there will be no failing tests while we handle this.
(Reporter)

Comment 6

7 years ago
I wouldn't change the name of the existing files but add '-nosound' or so to the new files. I kinda would love to have the sound available for users of Litmus/MozTrap. But at all that's amazing to hear! Thanks Rainer.
(Assignee)

Comment 7

7 years ago
(In reply to Henrik Skupin (:whimboo) from comment #6)
> I wouldn't change the name of the existing files but add '-nosound' or so to
> the new files. I kinda would love to have the sound available for users of
> Litmus/MozTrap. But at all that's amazing to hear! Thanks Rainer.

I agree with Henrik's point of view. This bug should be addressed in three stages:

1) Check-in the -nosound videos to litmus-data (existing videos will not be renamed)
2) Wait for them to sync to mozqa.com
3) Update the Endurance tests to use the new videos

We should not see any failing tests using this process.
(Assignee)

Comment 8

7 years ago
Created attachment 613311 [details] [diff] [review]
patch v1 (litmus-data)

Patch adds two new videos to the litmus-data repository:
 * sample-flv-video-10s-nosound.flv
 * sample-swf-video-10s-nosound.swf

I've tested the videos locally and they seem to work fine (video plays without sound). Alex, can you apply the patch locally and verify before I check it in?

Thanks
Assignee: nobody → anthony.s.hughes
Status: NEW → ASSIGNED
Attachment #613311 - Flags: review?(alex.lakatos)
(Reporter)

Comment 9

7 years ago
Anthony, why are both files without sound larger than the ones with sound?
(Assignee)

Comment 10

7 years ago
(In reply to Henrik Skupin (:whimboo) from comment #9)
> Anthony, why are both files without sound larger than the ones with sound?

Because they are not simply the same video,with the audio stripped. They are new videos without an audio track. The files are still only 10s longand less than 1MB so I think they will serve our purposes fine.
(Reporter)

Comment 11

7 years ago
But at least the swf version is a totally different movie. I would have thought that we really make use of the same video so that we are able to compare results better. Now we have multiple factors in it which makes it hard to figure out regressions. Not sure about the flv movie because I wasn't able to check it yet.
(Assignee)

Comment 12

7 years ago
I'm not sure I buy that argument, nor do I think debating it should block landing them. Feel free to convince me otherwise, but I think we should cross that bridge if and when we come to it.
(Reporter)

Comment 13

7 years ago
Well, it's totally up to you. Regarding the actual patch it should also include the appropriate HTML files with the nosound suffix at the same time. I don't see a reason why we would have to land a separate patch for it.
(Assignee)

Comment 14

7 years ago
(In reply to Henrik Skupin (:whimboo) from comment #13)
> Well, it's totally up to you. Regarding the actual patch it should also
> include the appropriate HTML files with the nosound suffix at the same time.
> I don't see a reason why we would have to land a separate patch for it.

Question is do we want to update the existing test html files to use *nosound* or do we want to add new ones? If we just edit the existing ones it means no downtime for the Mozmill tests which use them.
(Reporter)

Comment 15

7 years ago
I still think that there is a high value in having both versions available for testing. Who knows if we have to update the appropriate litmus tests to also cover the no-sound version. So I'm totally in favor of adding new files. But whatever we are doing here the Mozmill tests will have *no* downtime.
(Assignee)

Comment 16

7 years ago
Created attachment 615365 [details] [diff] [review]
patch v2

Updated the patch to include four new html test pages.
Attachment #613311 - Attachment is obsolete: true
Attachment #613311 - Flags: review?(alex.lakatos)
Attachment #615365 - Flags: review?(alex.lakatos)
(Reporter)

Comment 17

7 years ago
Comment on attachment 615365 [details] [diff] [review]
patch v2

Looks fine. I will land it right away.
Attachment #615365 - Flags: review?(alex.lakatos) → review+
(Reporter)

Comment 18

7 years ago
http://hg.mozilla.org/qa/litmus-data/rev/33c3eb2934d0

I will file a follow-up for the Mozmill tests so we can make use of the new files.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Component: Mozmill Tests → Infrastructure
QA Contact: mozmill-tests → infrastructure
Resolution: --- → FIXED
(Reporter)

Updated

7 years ago
Blocks: 745909
(Reporter)

Updated

7 years ago
Duplicate of this bug: 712601

Updated

5 months ago
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.