FUEL: .install-event-fired key in config still exists long after addon has been removed

RESOLVED DUPLICATE of bug 520142

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 520142
6 years ago
5 years ago

People

(Reporter: L. Mohan Arun, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

I was viewing about:config entries when I chanced upon this entry:

extensions.bartap@philikon.de.install-event-fired

this should have gotten removed since I uninstalled the bartab addon long ago!


Actual results:

I found this key-value pair still exists in the firefox config even though I had removed/uninstalled the corresponding addon.


Expected results:

When the addon is removed/uninstalled, remove its corresponding .install-event-fired key in the Firefox config.

Comment 1

6 years ago
This is probably from FUEL <http://mxr.mozilla.org/mozilla-central/source/toolkit/components/exthelper/extApplication.js#402>

FUEL is not actively developed, so this issue is unlikely to be fixed there. There's a general bug about cleaning up the preferences on uninstall - bug 520142.

I'm inclined to mark this a duplicate of 520142, any objections?
Severity: normal → minor
Component: Untriaged → General
OS: Windows 7 → All
QA Contact: untriaged → general
Hardware: x86 → All
Summary: .install-event-fired key in config still exists long after addon has been removed → FUEL: .install-event-fired key in config still exists long after addon has been removed
Version: 11 Branch → Trunk

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 520142
You need to log in before you can comment on or make changes to this bug.