Last Comment Bug 740769 - [Thunderbird, OSX 10.6] Intermittent "test_bug325418.js | test failed (with xpcshell return code: 0)" + "TEST-UNEXPECTED-FAIL | undefined | 2 == true"
: [Thunderbird, OSX 10.6] Intermittent "test_bug325418.js | test failed (with x...
Status: VERIFIED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- normal (vote)
: mozilla14
Assigned To: Serge Gautherie (:sgautherie)
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on:
Blocks: 325418 438871
  Show dependency treegraph
 
Reported: 2012-03-30 04:29 PDT by Serge Gautherie (:sgautherie)
Modified: 2012-11-25 19:31 PST (History)
5 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wontfix
wontfix
fixed


Attachments
(Av1) Fix multiple issues in test_bug325418.js [Checked in: Comments 3 and 19] (1.22 KB, patch)
2012-03-30 04:37 PDT, Serge Gautherie (:sgautherie)
bzbarsky: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review
(Bv1) Convert test_bug325418.js file to LF end-of-lines, Fix nsITimer.idl documentation [Checked in: Comment 12] (3.13 KB, patch)
2012-04-09 18:48 PDT, Serge Gautherie (:sgautherie)
bzbarsky: review+
Details | Diff | Splinter Review
(Cv1) test_bug325418.js: Further improvements to reduce/diagnose random (too long delay) failures (2.51 KB, patch)
2012-04-09 18:55 PDT, Serge Gautherie (:sgautherie)
bzbarsky: review-
Details | Diff | Splinter Review
(Cv1a) test_bug325418.js: Create separate observers, Initialize gStartTime[12] later, Use Date.now() instead of (new Date()).getTime(), "timer = null;" a bit later, Nits [Checked in: Comment 17] (2.58 KB, patch)
2012-04-09 19:42 PDT, Serge Gautherie (:sgautherie)
bzbarsky: review+
Details | Diff | Splinter Review

Description Serge Gautherie (:sgautherie) 2012-03-30 04:29:13 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTrunk/1332773443.1332778348.25322.gz
MacOSX 10.6 comm-central test xpcshell on 2012/03/26 07:50:43
s: tb2-darwin10-slave60

http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTrunk/1333064813.1333069752.32654.gz
MacOSX 10.6 comm-central test xpcshell on 2012/03/29 16:46:53
s: tb2-darwin10-slave61
{
TEST-UNEXPECTED-FAIL | /builds/slave/comm-central-macosx64-opt-unittest-xpcshell/build/xpcshell/tests/xpcom/tests/unit/test_bug325418.js | test failed (with xpcshell return code: 0), see following log:
>>>>>>>

TEST-INFO | (xpcshell/head.js) | test 1 pending

TEST-INFO | (xpcshell/head.js) | test 2 pending

TEST-INFO | (xpcshell/head.js) | test 2 finished

TEST-INFO | (xpcshell/head.js) | running event loop

TEST-UNEXPECTED-FAIL | undefined | 2 == true - See following stack:
JS frame :: /builds/slave/comm-central-macosx64-opt-unittest-xpcshell/build/xpcshell/head.js :: do_throw :: line 462
JS frame :: /builds/slave/comm-central-macosx64-opt-unittest-xpcshell/build/xpcshell/head.js :: _do_check_eq :: line 556
JS frame :: /builds/slave/comm-central-macosx64-opt-unittest-xpcshell/build/xpcshell/head.js :: do_check_eq :: line 577
JS frame :: /builds/slave/comm-central-macosx64-opt-unittest-xpcshell/build/xpcshell/head.js :: do_check_true :: line 591
JS frame :: /builds/slave/comm-central-macosx64-opt-unittest-xpcshell/build/xpcshell/tests/xpcom/tests/unit/test_bug325418.js :: <TOP_LEVEL> :: line 14

TEST-INFO | (xpcshell/head.js) | exiting test
<<<<<<<
}
Comment 1 Serge Gautherie (:sgautherie) 2012-03-30 04:37:36 PDT
Created attachment 610850 [details] [diff] [review]
(Av1) Fix multiple issues in test_bug325418.js
[Checked in: Comments 3 and 19]
Comment 2 Boris Zbarsky [:bz] 2012-04-05 13:29:01 PDT
Comment on attachment 610850 [details] [diff] [review]
(Av1) Fix multiple issues in test_bug325418.js
[Checked in: Comments 3 and 19]

r=me
Comment 3 Serge Gautherie (:sgautherie) 2012-04-05 14:09:01 PDT
Comment on attachment 610850 [details] [diff] [review]
(Av1) Fix multiple issues in test_bug325418.js
[Checked in: Comments 3 and 19]

https://hg.mozilla.org/mozilla-central/rev/da0d07b5ca1e


[Approval Request Comment]
Regression caused by (bug #): Bug 325418.
User impact if declined:  None, but (random-orange on) broken(!) test.
Testing completed (on m-c, etc.): This comment.
Risk to taking this patch (and alternatives if risky): None, test-only.
String changes made by this patch: None.
Comment 4 Alex Keybl [:akeybl] 2012-04-09 13:01:32 PDT
Comment on attachment 610850 [details] [diff] [review]
(Av1) Fix multiple issues in test_bug325418.js
[Checked in: Comments 3 and 19]

[Triage Comment]
Test-only fix. Approved for Aurora 13 and Beta 12.
Comment 5 Serge Gautherie (:sgautherie) 2012-04-09 18:48:01 PDT
Created attachment 613464 [details] [diff] [review]
(Bv1) Convert test_bug325418.js file to LF end-of-lines, Fix nsITimer.idl documentation
[Checked in: Comment 12]
Comment 6 Boris Zbarsky [:bz] 2012-04-09 18:52:44 PDT
Comment on attachment 613464 [details] [diff] [review]
(Bv1) Convert test_bug325418.js file to LF end-of-lines, Fix nsITimer.idl documentation
[Checked in: Comment 12]

r=me
Comment 7 Serge Gautherie (:sgautherie) 2012-04-09 18:55:26 PDT
Created attachment 613466 [details] [diff] [review]
(Cv1) test_bug325418.js: Further improvements to reduce/diagnose random (too long delay) failures

Patch A did not fully fix this "orange":

http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTrunk/1333900948.1333905770.17458.gz
MacOSX 10.6 comm-central test xpcshell on 2012/04/08 09:02:28
s: tb2-darwin10-slave62
{
TEST-UNEXPECTED-FAIL | /builds/slave/comm-central-macosx64-opt-unittest-xpcshell/build/xpcshell/tests/xpcom/tests/unit/test_bug325418.js | test failed (with xpcshell return code: 0), see following log:

TEST-UNEXPECTED-FAIL | /builds/slave/comm-central-macosx64-opt-unittest-xpcshell/build/xpcshell/tests/xpcom/tests/unit/test_bug325418.js | 3 == 1 - See following stack:

JS frame :: /builds/slave/comm-central-macosx64-opt-unittest-xpcshell/build/xpcshell/tests/xpcom/tests/unit/test_bug325418.js :: observeTC :: line 16
}

***

Here is a patch which should help further,
though I wonder whether it's a (random) box (slowness) issue :-|
Comment 8 Boris Zbarsky [:bz] 2012-04-09 18:59:10 PDT
Comment on attachment 613466 [details] [diff] [review]
(Cv1) test_bug325418.js: Further improvements to reduce/diagnose random (too long delay) failures

Please describe the actual changes made in your checkin comment.  That would have the side benefit of letting me know what you're trying to accomplish, exactly.
Comment 9 Serge Gautherie (:sgautherie) 2012-04-09 19:03:35 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTrunk/1333939806.1333944991.7137.gz
MacOSX 10.6 comm-central test xpcshell on 2012/04/08 19:50:06
s: tb2-darwin10-slave62
TEST-UNEXPECTED-FAIL | /builds/slave/comm-central-macosx64-opt-unittest-xpcshell/build/xpcshell/tests/xpcom/tests/unit/test_bug325418.js | 3 == 1 - See following stack:


http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTrunk/1334011952.1334017314.10437.gz
MacOSX 10.6 comm-central test xpcshell on 2012/04/09 15:52:32
s: tb2-darwin10-slave60
TEST-UNEXPECTED-FAIL | /builds/slave/comm-central-macosx64-opt-unittest-xpcshell/build/xpcshell/tests/xpcom/tests/unit/test_bug325418.js | 3 == 1 - See following stack:
Comment 10 Serge Gautherie (:sgautherie) 2012-04-09 19:24:40 PDT
Comment on attachment 613466 [details] [diff] [review]
(Cv1) test_bug325418.js: Further improvements to reduce/diagnose random (too long delay) failures

*"Duplicate" observer, just in (unlikely) case the first timer would be firing.
*Init gStartTime[12] later, to reduce the recorded delay a bit.
*Use Date.now() instead of (new Date()).getTime(): simpler (& faster?).
*"timer = null;" a bit later, as not needed earlier, fwiw.
*Nits.
Comment 11 Boris Zbarsky [:bz] 2012-04-09 19:28:19 PDT
Comment on attachment 613466 [details] [diff] [review]
(Cv1) test_bug325418.js: Further improvements to reduce/diagnose random (too long delay) failures

That should all go in the checkin comment.
Comment 12 Serge Gautherie (:sgautherie) 2012-04-09 19:34:40 PDT
Comment on attachment 613464 [details] [diff] [review]
(Bv1) Convert test_bug325418.js file to LF end-of-lines, Fix nsITimer.idl documentation
[Checked in: Comment 12]

http://hg.mozilla.org/mozilla-central/rev/6fe5b0271cd1
Comment 13 Serge Gautherie (:sgautherie) 2012-04-09 19:42:26 PDT
Created attachment 613474 [details] [diff] [review]
(Cv1a) test_bug325418.js: Create separate observers, Initialize gStartTime[12] later, Use Date.now() instead of (new Date()).getTime(), "timer = null;" a bit later, Nits
[Checked in: Comment 17]

Cv1, with comment 8 suggestion(s).
Comment 14 Boris Zbarsky [:bz] 2012-04-09 19:52:15 PDT
Comment on attachment 613474 [details] [diff] [review]
(Cv1a) test_bug325418.js: Create separate observers, Initialize gStartTime[12] later, Use Date.now() instead of (new Date()).getTime(), "timer = null;" a bit later, Nits
[Checked in: Comment 17]

r=me
Comment 15 :Ms2ger 2012-04-10 05:21:31 PDT
(In reply to Serge Gautherie (:sgautherie) from comment #12)
> Comment on attachment 613464 [details] [diff] [review]
> (Bv1) Convert test_bug325418.js file to LF end-of-lines, Fix nsITimer.idl
> documentation
> [Checked in: Comment 12]
> 
> http://hg.mozilla.org/mozilla-central/rev/6fe5b0271cd1

This was an inappropriate use of DONTBUILD.
Comment 16 Serge Gautherie (:sgautherie) 2012-04-10 06:52:45 PDT
(In reply to Ms2ger from comment #15)
> This was an inappropriate use of DONTBUILD.

Why?
Comment 17 Serge Gautherie (:sgautherie) 2012-04-10 07:02:06 PDT
Comment on attachment 613474 [details] [diff] [review]
(Cv1a) test_bug325418.js: Create separate observers, Initialize gStartTime[12] later, Use Date.now() instead of (new Date()).getTime(), "timer = null;" a bit later, Nits
[Checked in: Comment 17]

https://hg.mozilla.org/mozilla-central/rev/2374ebd5026f
Comment 18 Serge Gautherie (:sgautherie) 2012-04-10 15:45:53 PDT
Though I could tweak code order a bit again to reduce actual delay a bit more,
this test looks fine as it is now wrt its code.

V.Fixed, wrt that.

*****

(In reply to Serge Gautherie (:sgautherie) from comment #7)
> I wonder whether it's a (random) box (slowness) issue :-|

Still happening (as I expected :-|):

http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTrunk/1334080146.1334085169.24313.gz
MacOSX 10.6 comm-central test xpcshell on 2012/04/10 10:49:06
s: tb2-darwin10-slave62
{
TEST-UNEXPECTED-FAIL | /builds/slave/comm-central-macosx64-opt-unittest-xpcshell/build/xpcshell/tests/xpcom/tests/unit/test_bug325418.js | 2 == 1 - See following stack:

JS frame :: /builds/slave/comm-central-macosx64-opt-unittest-xpcshell/build/xpcshell/tests/xpcom/tests/unit/test_bug325418.js :: observeTC2 :: line 39
}

If someone wants to investigate the specific issue of these TB on OSX 10.6 builds,
please file a follow-up bug.
Comment 19 Jens Hatlak (:InvisibleSmiley) 2012-04-23 13:41:43 PDT
Comment on attachment 610850 [details] [diff] [review]
(Av1) Fix multiple issues in test_bug325418.js
[Checked in: Comments 3 and 19]

http://hg.mozilla.org/releases/mozilla-aurora/rev/4c7f697b3697
Comment 20 Serge Gautherie (:sgautherie) 2012-04-24 12:22:45 PDT
Missed Gecko 12 :-|

Note You need to log in before you can comment on or make changes to this bug.