Parasite pixels when zooming back out

RESOLVED WORKSFORME

Status

()

Core
Layout: View Rendering
RESOLVED WORKSFORME
6 years ago
a year ago

People

(Reporter: Yoric, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
All
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 610868 [details]
Screenshot demonstrating the issue

I have just encountered a reproducible painting bug on a slideshow I am currently preparing.
Created attachment 610869 [details]
The slideshow

To reproduce the problem, open the attached slideshow (index.html), place mouse on the image of iOS, let the image grow for a second or so, move mouse somewhere else. The bug is nearly 100% reproducible with this sample.
Also useful to know if this happens with different accelerated (or not) layer backends.
Keywords: regressionwindow-wanted
(In reply to Timothy Nikkel (:tn) from comment #2)
> Also useful to know if this happens with different accelerated (or not)
> layer backends.

How do I test that?
Version: unspecified → 12 Branch
The comment wasn't directed at you, but anyone who could test. You can uncheck use hardware acceleration in prefs under Advanced, General.

Comment 5

5 years ago
I can reproduce with HWA enabled/disabled both.
http://hg.mozilla.org/mozilla-central/rev/9274e6b53af4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120602134306


Graphics
Adapter Description : ATI Radeon HD 4300/4500 Series
Vendor ID : 0x1002
Device ID : 0x954f
Adapter RAM : 512
Adapter Drivers : aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version : 8.961.0.0
Driver Date : 4-5-2012
Direct2D Enabled : true
DirectWrite Enabled : true (6.1.7601.17789)
ClearType Parameters : Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 50 
WebGL Renderer : Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU Accelerated Windows : 1/1 Direct3D 10
AzureBackend : direct2d


        
        AzureBackenddirect2d

Comment 6

5 years ago
The ghost appears depend on windows size.
In case of content.innerWidth 1070px, content.innerHeight 665px,
The ghost appears under the pinture after shrink the image

Regression window(cached m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/c3a50afc2243
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111007 Firefox/10.0a1 ID:20111007031227
Bad:
http://hg.mozilla.org/mozilla-central/rev/bd1411e362fb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111007 Firefox/10.0a1 ID:20111007034151
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c3a50afc2243&tochange=bd1411e362fb


Regression window(cached m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/baa28d3f6296
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111006 Firefox/10.0a1 ID:20111006135449
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/94f2fa9f97b8
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111006 Firefox/10.0a1 ID:20111006153652
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=baa28d3f6296&tochange=94f2fa9f97b8

Updated

5 years ago
OS: Mac OS X → All
Version: 12 Branch → Trunk

Comment 7

5 years ago
Suspected 
Bug 684759
Blocks: 684759

Comment 8

5 years ago
In local build
Last good: ac647c00259a (with 8af101010da7+d8abcac1d00a+f195de86f363+94f2fa9f97b8)
First bad: 2465969e8c76 (with 8af101010da7+d8abcac1d00a+f195de86f363+94f2fa9f97b8)
Blocks: 689416
No longer blocks: 684759

Comment 9

5 years ago
It depend on size of content window.
Vertical ghost line appears for exsample:
content.innerWidth 723px
content.innerHeight 636px
Confirmed against Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120629030530.

Graphics
Adapter Description        ATI Radeon HD 4800 Series
Vendor ID        0x1002
Device ID        0x9442
Adapter RAM        512
Adapter Drivers        aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version        8.961.3.0
Driver Date        5-7-2012
Direct2D Enabled        true
DirectWrite Enabled        true (6.1.7601.17789)
ClearType Parameters        Gamma: 1800 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 400
WebGL Renderer        Google Inc. -- ANGLE (ATI Radeon HD 4800 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041) 
GPU Accelerated Windows        1/1 Direct3D 10
AzureBackend        direct2d
Keywords: regressionwindow-wanted → regression, testcase
20160502172042 Mozilla/5.0 (Windows NT 6.1; rv:46.0) Gecko/20100101 Firefox/46.0
20160602030220 Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0

I have tested your issue on latest FF release 46.0 and latest Nightly build and could not reproduce it. I have tested with HWA enabled/disabled.
Is this still reproducible on your end ? If yes, can you please retest this using latest FF release and latest Nightly build (https://nightly.mozilla.org/) and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E).
Flags: needinfo?(dteller)
Well, that was 4 years ago. I haven't encountered this problem in a long time.
Flags: needinfo?(dteller)
Thank you.

Based on Comment12 from the reporter, changing status to RESOLVED WORKS FOR ME.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.