Eve Online spaceship demo only renders invisible ships with visible exhaust

RESOLVED DUPLICATE of bug 775753

Status

()

Core
Canvas: WebGL
RESOLVED DUPLICATE of bug 775753
6 years ago
6 years ago

People

(Reporter: jaws, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: webgl-conformance, URL)

Attachments

(1 attachment)

Created attachment 611023 [details]
Screenshot of bug

I have tried toggling gfx.direct2d.disabled, gfx.direct2d.force-enabled, gfx.direct3d.prefer_10_1, gfx.direct2d.disabled with no change in rendering.

STR: 
1) Load the site in the URL field.
2) See invisible ships, similar to the one that Wonder Woman flies.

Expected:
Ship doesn't have invisibility cloak.

----------------------------------------------------------------------

  Application Basics

        Name
        Firefox

        Version
        14.0a1

        User Agent
        Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120329 Firefox/14.0a1

  Important Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.cache.disk.capacity
        1048576

        browser.cache.disk.smart_size.first_run
        false

        browser.cache.disk.smart_size_cached_value
        1048576

        browser.cache.memory.enable
        false

        browser.places.smartBookmarksVersion
        3

        browser.startup.homepage_override.buildID
        20120329040238

        browser.startup.homepage_override.mstone
        14.0a1

        browser.tabs.warnOnClose
        false

        dom.max_script_run_time
        0

        extensions.lastAppVersion
        14.0a1

        gfx.direct2d.disabled
        true

        gfx.direct3d.prefer_10_1
        true

        layers.acceleration.disabled
        true

        network.cookie.prefsMigrated
        true

        network.http.max-persistent-connections-per-proxy
        24

        places.database.lastMaintenance
        1333064915

        places.history.expiration.transient_current_max_pages
        104858

        places.history.expiration.transient_optimal_database_size
        167772160

        privacy.donottrackheader.enabled
        true

        privacy.sanitize.migrateFx3Prefs
        true

        security.warn_viewing_mixed
        false

  Graphics

        Adapter Description
        NVIDIA Quadro 1000M

        Vendor ID
        0x10de

        Device ID
        0x0dfa

        Adapter RAM
        2048

        Adapter Drivers
        nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um

        Driver Version
        8.17.12.8538

        Driver Date
        9-22-2011

        Adapter Description (GPU #2)
        Intel(R) HD Graphics Family

        Vendor ID (GPU #2)
        0x8086

        Device ID (GPU #2)
        0x0126

        Adapter RAM (GPU #2)
        Unknown

        Adapter Drivers (GPU #2)
        igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32

        Driver Version (GPU #2)
        8.15.10.2321

        Driver Date (GPU #2)
        3-6-2011

        Direct2D Enabled
        false

        DirectWrite Enabled
        false (6.1.7601.17776)

        ClearType Parameters
        ClearType parameters not found

        WebGL Renderer
        NVIDIA Corporation -- Quadro 1000M/PCI/SSE2 -- 4.2.0

        GPU Accelerated Windows
        0

  JavaScript

        Incremental GC
        1

  Library Versions

        Expected minimum version

        Version in use

        NSPR
        4.9
        4.9

        NSS
        3.13.3.0 Basic ECC
        3.13.3.0 Basic ECC

        NSS Util
        3.13.3.0
        3.13.3.0

        NSS SSL
        3.13.3.0 Basic ECC
        3.13.3.0 Basic ECC

        NSS S/MIME
        3.13.3.0 Basic ECC
        3.13.3.0 Basic ECC
Same issue here on Linux, but I've seen it run correctly in Firefox on Mac. Does it run correctly in Chrome on your computer?
Yeah it works correctly in Chrome Canary.
Is this a regression? This WFM on my home machine with Fx12:

Adapter Description  NVIDIA GeForce 8800 GTS
Vendor ID  0x10de
Device ID  0x0193
Adapter RAM   320
Adapter Driver  snvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version   8.17.12.9573
Driver Date   2-9-2012
Direct2D Enabled   true
DirectWrite Enabled   true (6.1.7601.17514)
ClearType Parameters   ClearType parameters not found
WebGL Renderer   Google Inc. -- ANGLE (NVIDIA GeForce 8800 GTS) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)
GPU Accelerated Windows   5/5 Direct3D 10
AzureBackend  direct2d
For me, this is broken already in Firefox 11 on Ubuntu 11.10 64bit radeon.

So this rather seems like something that depends on undefined behavior. Maybe something like the getAttribLocation gotcha, but I don't see any WebGL error here so it's not the trivial case.
I can reproduce the same result on Linux with:
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile 
OpenGL version string: 2.1 Mesa (git-63b5902)
wfm here (and it was smooth like butter):

WebGL Renderer: ATI Technologies Inc. -- ATI Radeon HD 5770 OpenGL Engine -- 2.1 ATI-7.18.11
GPU Accelerated Windows1/1 OpenGL

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20120331 Firefox/14.0a1
also fine on my windows machine:

NVIDIA GeForce GTX 560 Ti  
Google Inc. -- ANGLE (NVIDIA GeForce GTX 560 Ti  ) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)
1/1 Direct3D 10

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120331 Firefox/14.0a1
I checked if this app is rendering with any textures for which image data has not yet been uploaded (set a breakpoint at WebGLContext.h:1555): no, that is not the case.

So I'm really clueless, but the odds of this being a subtle bug in their application code at definitely higher than 90% so I feel that it's probably not worth investing more time in trying to debug this. Instead, we could try some outreach.
No longer blocks: 680721
Whiteboard: webgl-conformance
Awesome, confirmed on my thinkpad with webgl.prefer-native-gl=true.

Displays fine with ANGLE, broken with native GL on nVidia?
Also broken on the same machine on Linux.
WFM

Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20120528 Firefox/14.0a2
Adapter Description ATI Technologies Inc. -- ATI Radeon 3000 Graphics
Driver Version 3.3.11627
Depends on: 775753
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 775753
No longer depends on: 775753
You need to log in before you can comment on or make changes to this bug.