crash in XieFloImportDrawable

VERIFIED DUPLICATE of bug 74115

Status

()

Core
ImageLib
--
critical
VERIFIED DUPLICATE of bug 74115
17 years ago
8 years ago

People

(Reporter: Jens-Uwe, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14 i686; en-US; 0.8.1)
BuildID:    2001033005

todays build crashes VERY often in the function mentioned above. Since its the
first build I tried with libpr0n I try a guess, that it is because of this. I
did not have the problem with the 2001032921 build. The URL mentioned seems to
be good to reproduce this crash...

Reproducible: Always
Steps to Reproduce:
1. go to  http://www.userfriendly.org/static/
2. see mozilla crash

Actual Results:  Mozilla crashes

Expected Results:  Should not crash

I get the following stuff in the debugger:

Program received signal SIGSEGV, Segmentation fault.
0x409b7c21 in XieFloImportDrawable () from /usr/X11R6/lib/libXIE.so.6

where
#0  0x409b7c21 in XieFloImportDrawable () from /usr/X11R6/lib/libXIE.so.6
#1  0x4098d6cb in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgfx_gtk.so
#2  0x4098d86b in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgfx_gtk.so
#3  0x40996137 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgfx_gtk.so
#4  0x409961ea in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgfx_gtk.so
#5  0x4002f73d in nsRenderingContextImpl::DrawScaledImage () from
/home/jur/ftp/test/mozilla/libgkgfx.so
#6  0x40d9a080 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#7  0x40d872d1 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#8  0x40d83734 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#9  0x40d8359a in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#10 0x40d872d1 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#11 0x40d871ac in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#12 0x40e1c5c7 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#13 0x40e2b0f7 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#14 0x40e2afc2 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#15 0x40e2cf57 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#16 0x40e2ce45 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#17 0x40d872d1 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#18 0x40d871ac in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#19 0x40e21c3c in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#20 0x40d872d1 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#21 0x40e2761e in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#22 0x40d872d1 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#23 0x40d83734 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#24 0x40d8359a in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#25 0x40d872d1 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#26 0x40d83734 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#27 0x40d8359a in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#28 0x40d872d1 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#29 0x40d871ac in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#30 0x40d92c09 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#31 0x40db3b0f in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#32 0x40ede7b7 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgkview.so
#33 0x40ee69b6 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgkview.so
#34 0x40ee679f in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgkview.so
#35 0x40ee5a85 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgkview.so
#36 0x40ee7af0 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgkview.so
#37 0x40ede34d in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgkview.so
#38 0x404c160a in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#39 0x404c1535 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#40 0x404c4eb5 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#41 0x404c5035 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#42 0x404c4d79 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#43 0x40668cbf in g_idle_dispatch (source_data=0x404c4d30,
dispatch_time=0xbffff10c, user_data=0x0) at gmain.c:1364
#44 0x40667bd6 in g_main_dispatch (dispatch_time=0xbffff10c) at gmain.c:656
#45 0x40668203 in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#46 0x406683cc in g_main_run () at gmain.c:884
#47 0x4058700c in gtk_main () at gtkmain.c:807
#48 0x404b45ec in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#49 0x4045976a in nsJSUtils::mCachedSecurityManager () from
/home/jur/ftp/test/mozilla/components/libnsappshell.so
#50 0x804e0b4 in JS_PushArguments ()
#51 0x804e945 in JS_PushArguments ()
#52 0x40250a5e in __libc_start_main () at ../sysdeps/generic/libc-start.c:93
(Reporter)

Comment 1

17 years ago
74115 is marked as a blocker, so I sacrifice my bug ;-) 

*** This bug has been marked as a duplicate of 74115 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.