Closed Bug 741108 Opened 8 years ago Closed 8 years ago

Change background color for selected item in the reminder dialog in Windows 7 High Contrast mode (unreadable green on grey)

Categories

(Calendar :: OS Integration, defect)

Lightning 1.3
All
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: toad, Assigned: Paenglab)

Details

(Keywords: access)

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.16) Gecko/20120315 Iceweasel/3.5.16 (like Firefox/3.5.16)
Build ID: 20120315090431

Steps to reproduce:

Set Windows 7 to High Contrast theme (forces green on black in most apps). Set up a reminder in Lightning. Wait until the reminder dialog shows up.


Actual results:

Reminder dialog shows the selected item in green (from Windows) on light grey. This is not readable.


Expected results:

Like in #671119, Lightning should detect that Windows is using the High Contrast theme and change the background color (e.g. to the default from the windows theme, which here is black).

The individual can fix this via a userContent.css hack, but it should work out of the box for maximum accessibility.

The relevant theme CSS is here, but I was not easily able to find a theme which changes this:
http://mxr.mozilla.org/comm-central/source/calendar/base/themes/common/dialogs/calendar-alarm-dialog.css

The eventual solution locally was to put this in userChrome.css:
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

calendar-alarm-widget[selected="true"] {
    background-color: #000000 !important;
    padding: 0 5px;
}
OS: All → Windows 7
Keywords: access
Attached patch PatchSplinter Review
I've copied the system colors from richlistitem to calendar-alarm-widget. This works good on all systems. Only the Details... link isn't well readable under Mac and Linux with default Ubuntu theme. I decided to give the link the same color as the other text. With the underline it is still discoverable as link.

I removed also mozapps/skin/extensions/itemEnabledFader.png because this exists no more.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #611269 - Flags: review?(bv1578)
Attached image Reminder screenshot
Screenshot showing the link color issue under Mac and Ubuntu default. With Adwaita (the reminder on bottom) theme this would be no problem.

Because of this problem I gave for the link the same color as for the other text.
Comment on attachment 611269 [details] [diff] [review]
Patch

r=philipp

Too bad on the details link, but I don't see many alternatives.
Attachment #611269 - Flags: review?(bv1578) → review+
Pushed to comm-central: <http://hg.mozilla.org/comm-central/rev/faf0d25b0c60>
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4
Target Milestone: 1.4 → 1.6
Yes it might be. Sorry I didn't spot that when I searched.

There are 2 ways of going about it:

1 - take colour settings from the OS. This is what TB does (mostly). This allows the Windows HCB and any bespoke colour settings to work for the user who then gets the colours they want.

2 - Let Lightning set it's own colours. But it must set ALL colours which is what it fails to do. Ir sets some and takes others from the OS so we get these problems.

I have screen shots now to show that the white text on blue takes white from the OS but the blue background is set within Lightning.

Should I post these screen shots now?
You need to log in before you can comment on or make changes to this bug.