Plugin doorhanger reappears after switching tabs after Flash has been enabled

VERIFIED FIXED in Firefox 14

Status

()

Firefox for Android
General
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: Margaret)

Tracking

({testcase})

Trunk
Firefox 14
ARM
Android
testcase
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 +)

Details

(Whiteboard: [good first bug][mentor=jaws][lang=js], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
You need to have the "Tap to Play" setting enabled for plugins for this bug.

See url testcase, steps to reproduce:
- Make sure you have at least 2 tabs open
- Visit testcase, the plugin doorhanger appears after 2 seconds, ignore it by tapping outside of it.
- Tap on the first 'Tap here to activate plugin' plugin placeholder
- Tap on the 'Tap here to activate plugin' placeholder plugin
- Switch to another tab
- Switch back to this tab

Expected result:
- No plugin doorhanger appears, because Flash is already enabled on the page.

Actual result:
- Plugin doorhanger appears.

Tested in today's trunk Fennec Native build on the Samsung Galaxy SII.
Whiteboard: [good first bug][mentor=jwein][lang=js]
Whiteboard: [good first bug][mentor=jwein][lang=js] → [good first bug][mentor=jaws][lang=js]
(Reporter)

Updated

6 years ago
Blocks: 744060
(Assignee)

Comment 2

6 years ago
Created attachment 614207 [details] [diff] [review]
patch

Quick simple patch.

The call to playAllPlugins in the doorhanger button callback takes care of hiding the doorhanger for us, and this is the only other place we call playAllPlugins, so this is the only place we need to worry about hiding the doorhanger if it's been shown.
Assignee: nobody → margaret.leibovic
Attachment #614207 - Flags: review?(mark.finkle)
Attachment #614207 - Flags: review?(mark.finkle) → review+
blocking-fennec1.0: --- → +
(Assignee)

Comment 3

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/9135a11eb1a2
Target Milestone: --- → Firefox 14
https://hg.mozilla.org/mozilla-central/rev/9135a11eb1a2
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

6 years ago
Verified fixed in today's trunk build (2012-04-14) on the Samsung Galaxy SII.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.