Closed Bug 741134 Opened 8 years ago Closed 8 years ago

Plugin placeholder shown even when Site Setting says 'Play Plugins: Yes'

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 14

People

(Reporter: martijn.martijn, Assigned: Margaret)

References

()

Details

(Keywords: testcase, Whiteboard: [good first bug][mentor=jaws][lang=js])

Attachments

(1 file)

You need to have the "Tap to Play" setting enabled for plugins for this bug.

Steps to reproduce:
- Visit http://people.mozilla.org/~mwargers/tests/plugins/flash/flashembed_displaynone.html, the plugin doorhanger appears.
- Tap on the 'Yes' button for the "Would you like to play it" question. Let the checkbox checked for 'Don't ask again for this site'
- Visit http://people.mozilla.org/~mwargers/tests/plugins/flash/flashembed.html

Expected result:
- Flash plugins are shown on that page, no plugin placeholders.

Actual result:
- Plugin placeholders appear, no Flash plugins are shown.

Tested in today's trunk Fennec Native build on the Samsung Galaxy SII.
https://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/browser.js#1927 should check to see if the ALLOW permission has been added for "plugins", and if so, it should call |PluginHelper.playPlugin(plugin);|.
Whiteboard: [good first bug][mentor=jwein][lang=js]
Whiteboard: [good first bug][mentor=jwein][lang=js] → [good first bug][mentor=jaws][lang=js]
When implementing the "Don't ask again for this site" feature in bug 736278, I think I decided that would just be about pages with hidden plugins, since that's what the doorhanger is about. However, the string does say "%S contains plugin content. Would you like to play it?", so I think it makes sense to go ahead and play all plugins if the user flipped that permission.

Cc'ing Ian, since he's the UX guy helping out with this stuff.
Blocks: 736278
I agree with Margaret, we can let this messaging apply to all plugin content on the page / site, since we aren't really distinguishing between hidden / non hidden plugins in the notification.
Blocks: 744060
Attached patch patchSplinter Review
This is an easy low-risk win.

I did notice that the placeholder briefly appears before the plugin gets activated. Jared mentioned seeing this on desktop and was looking into checking the permissions on the platform side, which would help us out, too.
Assignee: nobody → margaret.leibovic
Attachment #613715 - Flags: review?(mark.finkle)
Comment on attachment 613715 [details] [diff] [review]
patch


>-        if (this.clickToPlayPluginsActivated) {
>+        // Check if plugins have already been activated for this page, or if the user
>+        // has set a permission to always play plugins on the site
>+        if (this.clickToPlayPluginsActivated ||
>+            Services.perms.testPermission(this.browser.currentURI, "plugins") == Services.perms.ALLOW_ACTION) {
>           PluginHelper.playPlugin(plugin);
>           return;
>         }

feel free to keep the code on one line to avoid indenting oddness. up to you
Attachment #613715 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/af7263971ad4
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Verified fixed, using the 2012-04-14 trunk build on the Samsung Galaxy SII.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.