Closed Bug 741173 Opened 8 years ago Closed 8 years ago

While trying to pan large image inside iframe, the large image shows up in the parent page

Categories

(Core :: Graphics, defect, P1)

ARM
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 728026
Tracking Status
blocking-fennec1.0 --- +

People

(Reporter: martijn.martijn, Assigned: ajuma)

References

()

Details

(Keywords: mobile, testcase)

Attachments

(2 files)

Attached image Screenshot of bug
Steps to reproduce:
- Visit testcase, wait until it has loaded
- Make a swipe move in one of the iframes, to let the iframe scroll

Result:
- See screenshot of bug
Attached file testcase
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → +
Blocks: 747791
Erin mentioned that this might be worth beta blocking on.
blocking-fennec1.0: + → ?
blocking-fennec1.0: ? → +
Priority: -- → P1
Component: General → Layout
Product: Fennec Native → Core
QA Contact: general → layout
Assignee: nobody → ajuma
Isn't this more a graphics bug than a layout bug?
Keywords: mobile
Component: Layout → Graphics
QA Contact: layout → thebes
This is likely a dupe of bug 728026, which I'm working on.
Assignee: ajuma → joe
Now that I've actually seen the bug, this isn't a duplicate of bug 728026.

I believe this happens because nsImageFrame doesn't take into account the scale factor of the presshell - or, at least, Ehsan has said something along those lines to me.
Assignee: joe → nobody
Assignee: nobody → ajuma
I tested the attached testcase with and without the patch for Bug 728026. Without the patch, the issue reproduces very easily. With the patch, I can't reproduce. So I think this is in fact a duplicate of Bug 728026.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 728026
You need to log in before you can comment on or make changes to this bug.