A more compact add-on listing to fit more on the screen (when many add-ons are installed)

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
--
enhancement
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: Willy_ Foo_Foo, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows; Windows NT 6.1; rv:9.0) Gecko/20120330 Firefox/9.0
Build ID: 20120401041203

Steps to reproduce:

90+ add-ons
Go-to add-ons manager
try scrolling fast with 50+ add-ons installed




Actual results:

have to scroll & scroll
to get to a certain add-on(large or small screens)
& a lot of space is wasted(prefer using lists & small icons)


Expected results:

should have an option to use list view(like small icons in themes)

Try this to understand what i mean

https://addons.mozilla.org/firefox/downloads/latest/358612/addon-358612-latest.xpi

to anyone with more than about 50 add-ons, you quite honestly need this. it does exactly what you think, compresses your add-on list to fit more on the screen. Simple, yet effective.
Having the bad habit to install, test, enable and disable addons all the time this come handy when the list grows out off the screen.
(Reporter)

Updated

6 years ago
Severity: normal → major
OS: Windows 7 → All
Priority: -- → P1
Hardware: x86 → All
Version: 14 Branch → 13 Branch

Updated

6 years ago
Severity: major → enhancement
Priority: P1 → --

Updated

6 years ago
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: untriaged → add-ons.manager
Summary: A option to compresses your add-on list to fit more on the screen → A more compact add-on listing to fit more on the screen (when many add-ons are installed)
Version: 13 Branch → Trunk
(Reporter)

Updated

6 years ago
Priority: -- → P1

Comment 1

6 years ago
Don't play with the priority field and don't add dependency links to various bugs (especially if they have nothing to do with this one). It won't get this bug fixed faster, you're just annoying people.

The 'paper-cut' bugs are a list of bugs that annoy a lot of people, and are good list of bugs to improve the general product. They're chosen by the mozilla developers, you shouldn't add random bugs to the list (especially if your the only one who has commented on it). See bug comment 0.
No longer blocks: 561125, 565510, 565512, 565517
Priority: P1 → --
(Reporter)

Updated

5 years ago
Priority: -- → P1

Updated

5 years ago
Whiteboard: [Advo]
(Reporter)

Updated

5 years ago
Version: Trunk → 21 Branch
Don't play with the Priority or the Version fields. Put https://addons.mozilla.org/en-US/firefox/addon/cam/ in the URL field.
(Reporter)

Updated

5 years ago
Version: 21 Branch → 25 Branch
(Reporter)

Updated

4 years ago
Version: 25 Branch → 33 Branch
(Reporter)

Updated

3 years ago
Version: 33 Branch → 37 Branch
(Reporter)

Updated

2 years ago
Version: 37 Branch → 47 Branch
"Cleanest Addons Manager" https://addons.mozilla.org/addon/cam/ looks nice from its AMO pictures; it supports Firefox and Thunderbird but (I don't know why) not seaMonkey.
"Slim Add-ons Manager" https://addons.mozilla.org/addon/slim-add-ons-manager/ supports all three.
Either of them will reduce the height of the add-on rows in the List pane, allowing more of them to be seen at a glance without scrolling.

IMHO it would be nice if the add-ons manager rows weren't as bulky out of the box, but since there are at least two add-ons which produce the desired effect I won't fight a WONTFIX.
Status: UNCONFIRMED → NEW
QA Whiteboard: [firefox-9-affected]
Ever confirmed: true
Priority: P1 → --
Whiteboard: [Advo] → [Advo] [workaround see comment #3]
Version: 47 Branch → Trunk
Not going to happen. UX decision. Moreover you can do that by extension if you don't like how it's now.
No longer blocks: 565513
Status: NEW → RESOLVED
Last Resolved: 2 years ago
QA Whiteboard: [firefox-9-affected]
Resolution: --- → WONTFIX
Whiteboard: [Advo] [workaround see comment #3]
You need to log in before you can comment on or make changes to this bug.