The default bug view has changed. See this FAQ.

Cannot drag & drop file path onto INPUT type=file(I can drag & drop file path onto Browse... button)

RESOLVED FIXED in Firefox 14

Status

()

Core
Editor
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Alice0775 White, Assigned: Ehsan)

Tracking

({regression})

14 Branch
mozilla15
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox14+ verified, firefox15+ verified)

Details

(Whiteboard: [qa+], URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/bbe5086163c9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120331 Firefox/14.0a1 ID:20120331161857


Cannot drag & drop file path onto INPUT type=file.
(I can  drag & drop file path onto Browse... button)

Steps to reproduce:
1. Open URL.
2. Drag file from Explorer onto rectangle area of the INPUT type=file 

Actual results:
  I cannot drag & drop file path

Expected results:
  I cannot drag & drop file path

Regression window(m-c),
Works:
http://hg.mozilla.org/mozilla-central/rev/d78e842b5973
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120324 Firefox/14.0a1 ID:20120324012131
Fails:
http://hg.mozilla.org/mozilla-central/rev/20a01901480f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120325 Firefox/14.0a1 ID:20120325031055
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d78e842b5973&tochange=20a01901480f



Regression window(m-i),
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c216e1c38010
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120323 Firefox/14.0a1 ID:20120323082312
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/13cf485e1d1c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120323 Firefox/14.0a1 ID:20120323084412
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c216e1c38010&tochange=13cf485e1d1c

Suspected:
45bf5d610be2	Ehsan Akhgari — Bug 737889 - Part 2: Stop the propagarion of drag/drop events over non-editable content; r=roc

I am not sure this is a intentional change or not.
(Reporter)

Comment 1

5 years ago
Sorry.I mean.

Expected results:
  I can drag & drop file path
tracking-firefox14: --- → ?
(Assignee)

Comment 2

5 years ago
Created attachment 611568 [details] [diff] [review]
Patch (v1)

We need to exempt file control frames here because they will be handled by the nsFileControlFrame class.
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #611568 - Flags: review?(roc)

Updated

5 years ago
tracking-firefox14: ? → +
(Assignee)

Comment 3

5 years ago
roc: ping
(Assignee)

Updated

5 years ago
Attachment #611568 - Flags: review?(bzbarsky)
(Assignee)

Comment 4

5 years ago
Note to roc and bz: this needs to get in by tomorrow to get to the Firefox 14 beta code freeze.
(Assignee)

Updated

5 years ago
tracking-firefox15: --- → +
Comment on attachment 611568 [details] [diff] [review]
Patch (v1)

r=me if you drop the stray backslash in this line:

+    if ((mEditor->IsReadonly() || mEditor->IsDisabled()) &&\
Attachment #611568 - Flags: review?(bzbarsky) → review+
(Assignee)

Comment 6

5 years ago
Thanks for the review!

https://hg.mozilla.org/integration/mozilla-inbound/rev/245368bc3e2f
Target Milestone: --- → mozilla15
(Assignee)

Comment 7

5 years ago
Comment on attachment 611568 [details] [diff] [review]
Patch (v1)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 737889
User impact if declined: Drag and drop on file controls will break if the user drops on the Browse button.
Testing completed (on m-c, etc.): Tested manually
Risk to taking this patch (and alternatives if risky): Minimal.
String or UUID changes made by this patch: None.
Attachment #611568 - Flags: review?(roc) → approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/245368bc3e2f
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 9

5 years ago
Comment on attachment 611568 [details] [diff] [review]
Patch (v1)

[Triage Comment]
Fixes drag+drop. Approved for Aurora 14.
Attachment #611568 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 10

5 years ago
http://hg.mozilla.org/releases/mozilla-aurora/rev/ff0d77a61963
status-firefox14: --- → fixed
status-firefox15: --- → fixed
File from Explorer can be dropped in rectangle area of data:text/html;charset=utf-8,<input type%3D"file">
Verified fixed on Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0b7
status-firefox14: fixed → verified
Whiteboard: [qa+]paul.silaghi

Comment 12

5 years ago
Verified as fixed on:
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0

When files are dragged and dropped onto INPUT type=file, their right path is entered in the box.
status-firefox15: fixed → verified
Whiteboard: [qa+]paul.silaghi → [qa+]
You need to log in before you can comment on or make changes to this bug.