Last Comment Bug 741248 - pymake builds fail in nsIDOMBatteryManager.h or nsIDOMNavigatorBattery.h since the Paris bindings landed
: pymake builds fail in nsIDOMBatteryManager.h or nsIDOMNavigatorBattery.h sinc...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: x86_64 Windows 7
: -- critical with 2 votes (vote)
: mozilla14
Assigned To: Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: 740069
  Show dependency treegraph
 
Reported: 2012-04-01 15:31 PDT by Ryan VanderMeulen [:RyanVM]
Modified: 2012-04-09 17:41 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix? (3.18 KB, patch)
2012-04-05 09:39 PDT, Takanori MATSUURA
khuey: review-
Details | Diff | Splinter Review

Description Ryan VanderMeulen [:RyanVM] 2012-04-01 15:31:29 PDT
This is my first build since the Paris bindings landed. I'm assuming it's related. This is with a completely empty objdir to start.

creating dom/base/test/Makefile
WARNING: Token 'WHITESPACE' defined, but not used
WARNING: c:\mozbuild\mozilla-central\dom\bindings\parser\WebIDL.py:2524: Rule 'OtherOrComma' defined, but not used
WARNING: There is 1 unused token
WARNING: There is 1 unused rule
WARNING: Symbol 'OtherOrComma' is unreachable
WARNING: Symbol 'Other' is unreachable
Generating LALR tables
PrototypeList.h hasn't changed - not touching it
Common.h hasn't changed - not touching it
Common.cpp hasn't changed - not touching it
nsIDOMBatteryManager.idl
nsIDOMNavigatorBattery.idl
main() takes no arguments (1 given)
Traceback (most recent call last):
  File "c:\mozbuild\mozilla-central\build\pymake\pymake\process.py", line 213, in run
    m.__dict__[self.method](self.argv)
TypeError: main() takes no arguments (1 given)
None
c:\mozbuild\mozilla-central\config\rules.mk:1479:0: command 'pythonpath main \
  -Ic:/mozbuild/mozilla-central/other-licenses/ply \
  -Ic:/mozbuild/mozilla-central/xpcom/idl-parser \
  c:/mozbuild/mozilla-central/xpcom/idl-parser/header.py --cachedir=../../xpcom/idl-parser -Ic:/mozbuild/mozilla-central/dom/battery -I../../dist/idl c:/mozbuild/mozilla-central/dom/battery/nsIDOMBatteryManager.idl -d .deps/nsIDOMBatteryManager.h.pp -o _xpidlgen/nsIDOMBatteryManager.h' failed, return code -127
<export>: Found error
<export>: Found error
c:\mozbuild\mozilla-central\config\makefiles\target_export.mk:67:0: command 'c:/mozbuild/python/python.exe c:/mozbuild/mozilla-central/build/pymake/pymake/../make.py -C battery export' failed, return code 2
c:\mozbuild\mozilla-central\config\makefiles\target_export.mk:54:0: command 'c:/mozbuild/python/python.exe c:/mozbuild/mozilla-central/build/pymake/pymake/../make.py -C dom export' failed, return code 2
c:\mozbuild\mozilla-central\config\rules.mk:740:0: command 'c:/mozbuild/python/python.exe c:/mozbuild/mozilla-central/build/pymake/pymake/../make.py export_tier_platform' failed, return code 2
c:\mozbuild\mozilla-central\config\rules.mk:706:0: command 'c:/mozbuild/python/python.exe c:/mozbuild/mozilla-central/build/pymake/pymake/../make.py  tier_platform' failed, return code 2
c:\mozbuild\mozilla-central\client.mk:369:0: command 'c:/mozbuild/python/python.exe c:/mozbuild/mozilla-central/build/pymake/pymake/../make.py -s -j 4 -C c:/mozbuild/mozilla-central/objdir-fx-vc10' failed, return code 2
c:\mozbuild\mozilla-central\client.mk:220:0: command 'c:/mozbuild/python/python.exe c:/mozbuild/mozilla-central/build/pymake/pymake/../make.py -f c:/mozbuild/mozilla-central/client.mk realbuild MOZ_PROFILE_GENERATE=1 MOZ_PGO_INSTRUMENTED=1' failed, return code 2
c:\mozbuild\mozilla-central\client.mk:182:0: command 'c:/mozbuild/python/python.exe c:/mozbuild/mozilla-central/build/pymake/pymake/../make.py -f c:/mozbuild/mozilla-central/client.mk profiledbuild' failed, return code 2
Comment 1 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-04-01 15:34:57 PDT
Yeah, bent and I have been seeing this too.  It usually goes away if you make again.
Comment 2 Ryan VanderMeulen [:RyanVM] 2012-04-01 15:46:26 PDT
I filed after it failed twice in a row for me. I thought maybe it just needed a clobber after the first one.
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2012-04-01 18:02:12 PDT
That's odd.  This is not running through our new-binding code, obviously.  Kyle, I didn't think we made changes to the main idl parser, right?  Certainly nothing about it in the diff.

Ryan, if you can reproduce this reliably, would you be willing to try bisecting?
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-04-02 15:35:49 PDT
Confirmed using hg revert. Each test started with an empty objdir.

http://hg.mozilla.org/mozilla-central/rev/031949d40753 - WORKS
http://hg.mozilla.org/mozilla-central/rev/1bdb337e3136 - FAILS

To be clear, I'm building with pymake on Windows 7 x64 SP1. I'm using python 2.7.2, which is what ships with MozillaBuild 1.6. I've reproduced it on two different computers as well (same Windows and MozillaBuild versions, though).

Also, the failure is in nsIDOMNavigatorBattery.h, not nsIDOMBatteryManager.h. Sorry about that.
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-04-02 15:37:44 PDT
Actually, it appears that it can fail in either. The log in comment 0 shows nsIDOMBatteryManager.h, but the builds are failing in nsIDOMNavigatorBattery.h in my current tests.
Comment 6 Mark Capella [:capella] 2012-04-03 05:55:57 PDT
I just got the problem also ... after recent nightly pull my build worked fine, but I needed a clobber and then this came up.
Comment 7 Timo Tolonen 2012-04-03 16:41:36 PDT
The exact spot where it fails seems to be a bit random. My builds are failing at nsISmsDatabaseService.h. If I start the build again with dirty obj dir, the build works.
Comment 8 Mike Conley (:mconley) 2012-04-04 10:06:37 PDT
Thunderbird developer here.  This just showed up for me too.

A few build attempts and it goes away, which is disturbing.
Comment 9 :aceman 2012-04-04 13:25:39 PDT
I get a very similar output on Linux.
Comment 10 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-04-04 13:48:19 PDT
(In reply to :aceman from comment #9)
> I get a very similar output on Linux.

Using pymake?
Comment 11 David :Bienvenu 2012-04-04 13:50:57 PDT
I'm using pymake on windows. 15 or so build attempts and none have got past this error.
Comment 12 :aceman 2012-04-04 14:00:05 PDT
khuey, I use the default build: gmake -f client.mk
Comment 13 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-04-04 14:04:00 PDT
(In reply to :aceman from comment #12)
> khuey, I use the default build: gmake -f client.mk

Please file a separate bug for whatever you're seeing then.
Comment 14 :aceman 2012-04-04 14:36:16 PDT
I don't think that is needed.

I heard you backed out the WebIDL parser update and it builds now for me too.
Comment 15 Makoto Kato [:m_kato] 2012-04-04 19:25:33 PDT
When using parallel (-jN) option on pymake, this seems to be occur.
Comment 16 Ryan VanderMeulen [:RyanVM] 2012-04-04 19:26:56 PDT
I use -j 4
Comment 17 Takanori MATSUURA 2012-04-05 03:34:10 PDT
According to
https://hg.mozilla.org/mozilla-central/rev/ed9cbe6a817e
$(PYTHON_PATH) is extracted to fix this bug.

There are many $(PYTHON_PATH) using in m-c.
Why $PYTHON_PATH only here makes build failure?
Comment 18 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-04-05 09:09:20 PDT
(In reply to Takanori MATSUURA from comment #17)
> There are many $(PYTHON_PATH) using in m-c.
> Why $PYTHON_PATH only here makes build failure?

I have no idea, I'm just stabbing in the dark here.

Would like to hear if the failures go away for people after that cset.
Comment 19 Takanori MATSUURA 2012-04-05 09:39:36 PDT
Created attachment 612577 [details] [diff] [review]
Fix?

I've formatted pythonpath command lines same as xpcom/idl-parser/Makefile.in.
This means only one variable to be extracted is set per one line.

I'm not sure this is correct because I don't have Windows environment.
Comment 20 H. Hofer 2012-04-05 11:31:48 PDT
Looks good with https://hg.mozilla.org/mozilla-central/rev/ed9cbe6a817e (Win 7 x64, pymake -j4, building comm-central)!

Tried twice with new objdir (which always failed before).
Comment 21 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-04-05 11:36:40 PDT
Comment on attachment 612577 [details] [diff] [review]
Fix?

Review of attachment 612577 [details] [diff] [review]:
-----------------------------------------------------------------

No, this is what I don't want to do.  $(PYTHON_PATH) causes pymake to run these commands in a special mode which is what is failing here.
Comment 22 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-04-05 11:40:56 PDT
(In reply to H. Hofer from comment #20)
> Looks good with https://hg.mozilla.org/mozilla-central/rev/ed9cbe6a817e (Win
> 7 x64, pymake -j4, building comm-central)!
> 
> Tried twice with new objdir (which always failed before).

Excellent.  Is anyone else still seeing these failures after https://hg.mozilla.org/mozilla-central/rev/ed9cbe6a817e?
Comment 23 Ryan VanderMeulen [:RyanVM] 2012-04-05 15:57:37 PDT
Working fine for me as well.
Comment 24 Paul Adenot (:padenot) 2012-04-09 13:33:04 PDT
I can't build on Windows 7, VS2010 with a fresh tree, just pulled, (91225:17e4143dd6f0). The error is more or less what comment 0 says (full output : http://pastebin.mozilla.org/1561032).
Comment 25 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-04-09 13:49:48 PDT
I reapplied the hacky fix to the other targets in this directory.

https://hg.mozilla.org/mozilla-central/rev/96a1ab35f765
Comment 26 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-04-09 17:41:52 PDT
And http://hg.mozilla.org/mozilla-central/rev/7702bca6b64d

Note You need to log in before you can comment on or make changes to this bug.