Firefox renders font poorly in certain pdf files

RESOLVED DUPLICATE of bug 738648

Status

()

Firefox
PDF Viewer
RESOLVED DUPLICATE of bug 738648
6 years ago
6 years ago

People

(Reporter: Alan Bortu, Unassigned)

Tracking

({fonts})

14 Branch
fonts
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

6 years ago
Created attachment 611343 [details]
Firefox 14, built in pdf reader

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120401 Firefox/14.0a1
Build ID: 20120401192420

Steps to reproduce:

On the latest nightly build that I had downloaded from https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-win32/1333333460/ I tried to read a pdf file from my universities website.


Actual results:

When I opened the pdf file in a new tab, I found the font rendering was very ugly (see uploaded picture). This does not happen in chrome of with the SumatraPDF plugin. The pdf is located here: http://www.cs.utoronto.ca/~tff/165/lectures/ch6.pdf


Expected results:

It should have rendered the font normally without all the jagged edges.
(Reporter)

Comment 1

6 years ago
Created attachment 611344 [details]
Chrome rendering the font
(Reporter)

Updated

6 years ago
Component: Untriaged → PDF Viewer
Keywords: fonts

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: untriaged → pdf-viewer
Hardware: x86_64 → All

Comment 2

6 years ago
Created attachment 612005 [details]
PDF Viewer vs Evince on Ubuntu 10.10 64 bits

I have attached a comparison between PDF Viewer 0.2.414 and Evince on Ubuntu 10.10 64 bits and indeed fonts are poorly rendered on PDF Viewer
(Reporter)

Updated

6 years ago
OS: Windows 7 → All
(Reporter)

Comment 3

6 years ago
The problem seems to be fixed in this pdf but I have found another one where the text is not displayed properly. You need a university account to access the file so I have just uploaded it instead.

http://ompldr.org/vZjNrdw
(Reporter)

Comment 4

6 years ago
Created attachment 651656 [details]
New pdf with similar problem

Comment 5

6 years ago
the new PDF was scanned. this is an anti-aliasing problem. duplicate of bug 738648
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 738648
You need to log in before you can comment on or make changes to this bug.