Last Comment Bug 741287 - expandlibs_gen ignores missing files
: expandlibs_gen ignores missing files
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Mike Hommey [:glandium]
:
:
Mentors:
Depends on:
Blocks: 644608
  Show dependency treegraph
 
Reported: 2012-04-02 00:13 PDT by Mike Hommey [:glandium]
Modified: 2012-04-06 11:49 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Make expandlibs_gen.py error out when given a missing file (3.67 KB, patch)
2012-04-02 00:16 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review
part 2 - Fix layout/build/Makefile.in for missing libraries (2.97 KB, patch)
2012-04-02 00:16 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-04-02 00:13:37 PDT
This was revealed after landing bug 644608: expandlibs_gen happily works when some files are missing, and with bug 644608, dependencies are created for these missing files, and since they never exist, bug 644608 failed.
Comment 1 Mike Hommey [:glandium] 2012-04-02 00:16:21 PDT
Created attachment 611371 [details] [diff] [review]
Make expandlibs_gen.py error out when given a missing file
Comment 2 Mike Hommey [:glandium] 2012-04-02 00:16:37 PDT
Created attachment 611372 [details] [diff] [review]
part 2 - Fix layout/build/Makefile.in for missing libraries
Comment 3 Ted Mielczarek [:ted.mielczarek] 2012-04-05 11:29:06 PDT
Comment on attachment 611372 [details] [diff] [review]
part 2 - Fix layout/build/Makefile.in for missing libraries

Review of attachment 611372 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/build/Makefile.in
@@ +149,5 @@
>  ifdef MOZ_B2G_RIL #{
> +SHARED_LIBRARY_LIBS	+= \
> +	$(DEPTH)/dom/system/gonk/$(LIB_PREFIX)domsystemgonk_s.$(LIB_SUFFIX) \
> +	$(DEPTH)/dom/telephony/$(LIB_PREFIX)domtelephony_s.$(LIB_SUFFIX) \
> +	$(NULL)

two-space indent, not tabs here, please.

Note You need to log in before you can comment on or make changes to this bug.