Establishing WebSocket connection fails unexpectedly

RESOLVED WORKSFORME

Status

()

Core
Networking: WebSockets
--
minor
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Ihor Kaharlichenko, Unassigned)

Tracking

11 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Steps to reproduce:

# Start a fresh firefox instance (while no other instances were running)
# Proceed to websocket test page (tested on http://websocket.org/echo.html and a local copy of http://gitorious.org/qtwebsocket/qtwebsocket/blobs/b90770beb3b0f3b9265fc558e05f4f638c21c213/Example/Client/clientExample.html)
# Hit "Connect" button

Expected behavior:
"CONNECTED" message appear in the Log textarea.

Actual behavior:
In 7 of 10 test runs I got
    DISCONNECTED
    ERROR: undefined
in the Log textarea.

While testing against local websocket server running on port 1337 I monitored network activity via tcpdump like this:

# tcpdump -i lo -vvv tcp port 1337

The failing connection attempts didn't emit any network traffic at all, while successful ones did.
(Reporter)

Comment 1

6 years ago
I am running Linux Mint 12 on amd64, firefox is installed from official Ubuntu repositories.

I tried to reproduce this issue on 5 different Ubuntu 11.10/amd64 hosts and one Linux Mint 12, but didn't manage to reproduce this bug.

Disabling all the addons (but not plugins) on my PC didn't change the situation: I still got 70% chance to get websocket connection problems.

Creating a new Firefox profile on my PC solved the issue for me: 10 runs of Firefox with 10 connect/disconnect attempts each didn't yield a single connection problem.

So the conclusion is that I messed my profile somehow. All the "network.websocket.*" options shown in about:config are set to defaults. If someone is interested in narrowing down this issue I will be glad to provide any other info asked.
Severity: normal → minor

Updated

6 years ago
Component: Untriaged → Networking: WebSockets
Product: Firefox → Core
QA Contact: untriaged → networking.websockets
Ihor: 

Thanks for trying so hard to report and reproduce this.  I'm closing this for now since we have no steps to reproduce, but if you see it again please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.