bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

crash in mozilla::AndroidLayerRendererFrame::BeginDrawing

RESOLVED WORKSFORME

Status

()

Core
Widget: Android
--
critical
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: xti, Assigned: bnicholson)

Tracking

({crash, testcase})

Trunk
ARM
Android
crash, testcase
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 +)

Details

(Whiteboard: [native-crash], crash signature, URL)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-fee1462d-0404-4472-9915-3eaaf2120402 .
============================================================= 

Frame 	Module 	Signature 	Source
0 	libdvm.so 	libdvm.so@0x4866a 	
1 	libdvm.so 	libdvm.so@0x4ec85 	
2 	libdvm.so 	libdvm.so@0x48653 	
3 	libxul.so 	_JNIEnv::CallVoidMethod 	jni.h:631
4 	libxul.so 	mozilla::AndroidLayerRendererFrame::BeginDrawing 	widget/android/AndroidJavaWrappers.cpp:786
5 	libxul.so 	nsWindow::DrawWindowUnderlay 	widget/android/nsWindow.cpp:2279
6 	libxul.so 	mozilla::layers::LayerManagerOGL::Render 	gfx/layers/opengl/LayerManagerOGL.cpp:806
7 	libxul.so 	mozilla::layers::LayerManagerOGL::EndTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:454
8 	libxul.so 	mozilla::layers::LayerManagerOGL::EndEmptyTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:427
9 	libxul.so 	mozilla::layers::CompositorParent::Composite 	gfx/layers/ipc/CompositorParent.cpp:224
10 	libxul.so 	RunnableMethod<mozilla::layers::CompositorParent, void , Tuple0>::Run 	ipc/chromium/src/base/tuple.h:383
11 	libxul.so 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:318
12 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:326
13 	libxul.so 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:426
14 	libxul.so 	base::MessagePumpDefault::Run 	ipc/chromium/src/base/message_pump_default.cc:23
15 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
16 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
17 	libxul.so 	base::Thread::ThreadMain 	ipc/chromium/src/base/thread.cc:156
18 	libxul.so 	ThreadFunc 	ipc/chromium/src/base/platform_thread_posix.cc:26
19 	libc.so 	__thread_entry 	
20 	libc.so 	pthread_create 

Steps to reproduce:
1. Open Fennec
2. Go to http://people.mozilla.org/~mwargers/tests/contenteditable/contenteditable_focus_blur.htm (http://goo.gl/bbDZt)
3. Wait until Fennec will crash

--
Firefox 14.0a1 (2012-04-01)
Device: HTC Desire
OS: Android 2.2

Updated

6 years ago
Duplicate of this bug: 741307

Updated

6 years ago
Component: General → Widget: Android
Product: Fennec Native → Core
QA Contact: general → android
Summary: crash in _JNIEnv::CallVoidMethod → crash in mozilla::AndroidLayerRendererFrame::BeginDrawing
Whiteboard: [native-crash]
Duplicate of this bug: 742429
Keywords: testcase
(Reporter)

Updated

6 years ago
Crash Signature: [@ _JNIEnv::CallVoidMethod] → [@ _JNIEnv::CallVoidMethod] [@ JNI_CreateJavaVM | _JNIEnv::CallVoidMethod]
Still crashes in current native trunk build on the HTC Desire HD.
blocking-fennec1.0: --- → ?
Assignee: nobody → bnicholson
blocking-fennec1.0: ? → +
(Assignee)

Comment 4

6 years ago
I've tried this on several different phones but can't reproduce. Can you still make this crash? Maybe it's specific to the HTC Desire.
(Reporter)

Comment 5

6 years ago
This crash doesn't occur anymore on the latest Nightly. Closing bug as WFM. Please reopen if it will occur again.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Updated

6 years ago
Depends on: 748531
You need to log in before you can comment on or make changes to this bug.