Closed Bug 741310 Opened 10 years ago Closed 10 years ago

POSTs that take longer than 10 seconds return undefined

Categories

(Core :: Networking, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 739617

People

(Reporter: ferongr, Unassigned)

Details

Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20120401 Firefox/14.0a1

STR:

1: Go to http://omploader.org/
2: Open console (CTRL+SHIFT-K) and only show Network events (unselect all buttons but the "Net" one)
3: Click "Browse" and select a reasonably large file to upload (it should take more than 15 seconds on your connection).
4: Click "OMPLOAD"
5: Observe console.

You should see a line like "POST http://ompldr.org/upload [undefined 10078ms]" and you will get a "The connection was reset" error screen. Retrying the above will always return undefined to the POST at around 10000 to 11500ms. This happens on many sites I tried that allow you to upload files. Tested with a new profile and the issue persists. 

Issue does not appear on Aurora, Opera Next or Internet Explorer 8.

FWIW I'm using WiFi to connect to the Internet and (as indicated by the platform field) Windows XP SP3. Issue might not reproduce on other platforms or networking methods.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 739617
You need to log in before you can comment on or make changes to this bug.