Notify Nightly users of new features

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: A, T, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I'm in constant contact with several Nightly users daily, who either moved from stable, Chrom(ium) or IE,  and I always get asked 'what's new in Nightly", which I follow on by saying "check it yourself". 

Checking out bugzilla or the mercurial repository is frankly, too difficult for most users, I myself have a difficult time navigating through the latter. 

So I propose Mozilla spawns a tab on startup for each build that comes with something 'juicy' that would interest most users, in the tab it should list the feature, its basic mechanics and a bugzilla link to the appropriate bug in case they see some bugs to report. 
You already spawn a new tab when Nightly gets a version bump or when a new profile is put in place? This shouldn't be too difficult to implement. 

Aurora and other downstream builds don't need this since they already come with their own changelogs, unlike Nightly which gets no documentation on new features besides word of mouth.

Communication between the Nightly community and Mozdevs is basically nonexistent outside of IRC and bugzilla, why not improve it?
This would probably be rather impractical to do on every nightly update, as changes can be pushed, then backed out, and having to create a page, update it and keep it maintained for every night would be a huge time drain.
(Reporter)

Comment 2

6 years ago
(In reply to Tyler Downer [:Tyler] from comment #1)
> This would probably be rather impractical to do on every nightly update, as
> changes can be pushed, then backed out, and having to create a page, update
> it and keep it maintained for every night would be a huge time drain.

That's the reason I mentioned that only big features should be included, like for example the upcoming download manager, in content preferences or silent updates. 

Most people are not interested in some random xpcom or DOM , or P2 memshrink fixes,  they are interested in bigger fish. 

For example, this page shows what interests most users.
https://wiki.mozilla.org/Features/Release_Tracking
The cost of doing this outweighs the benefits. Generating "What's new" and "release notes" type pages tends to be labor intensive, and so doing it daily (or even weekly), especially this things landing and getting backed out, will take a lot of someone's time.

We recently improved our release notes, not sure if we're doing it for Aurora/Beta yet but that might be an option. But not Nightly right now. [http://www.mozilla.org/en-US/firefox/11.0/releasenotes/]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
FWIW, a Twitter Account "Firefox Nightly" posting new Stuff occasionally is available:
https://twitter.com/#!/FirefoxNightly
You need to log in before you can comment on or make changes to this bug.