Crash on launch Apprunner M6 build - RAPTORHTML.DLL

VERIFIED DUPLICATE of bug 7802

Status

P3
critical
VERIFIED DUPLICATE of bug 7802
20 years ago
2 years ago

People

(Reporter: leger, Assigned: jevering)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Many Talkback reports on this.  Coming in from outside on M6 release for Win32
platform...95, 98 and NT have all had this crash.

 Trigger Type:  Program Crash

 Trigger Reason:  Access violation


 Call Stack:    (Signature = RAPTORHTML.DLL + 0x25ced (0x016a5ced) efb39791)

   RAPTORHTML.DLL + 0x25ced (0x016a5ced)


   RAPTORHTML.DLL + 0x25dd6 (0x016a5dd6)


   RAPTORHTML.DLL + 0x2550b (0x016a550b)


   RAPTORHTML.DLL + 0x25499 (0x016a5499)


   RAPTORHTML.DLL + 0x84e71 (0x01704e71)


   RAPTORHTML.DLL + 0x216f0 (0x016a16f0)


   RDF.DLL + 0x15163 (0x01795163)


   RDF.DLL + 0x132ad (0x017932ad)


   RAPTORHTMLPARS.DLL + 0xe2a9 (0x0144e2a9)


   RAPTORHTMLPARS.DLL + 0xaf7d (0x0144af7d)


   RAPTORHTMLPARS.DLL + 0xb3ba (0x0144b3ba)


   RAPTORHTMLPARS.DLL + 0xafe8 (0x0144afe8)


   RDF.DLL + 0x21248 (0x017a1248)


   NETLIB.DLL + 0x3cce (0x00473cce)


   RAPTORWEB.DLL + 0x2a1b (0x00d82a1b)


   NETLIB.DLL + 0x298c (0x0047298c)


   NETLIB.DLL + 0x2817 (0x00472817)


   PLDS3.DLL + 0x18ee (0x004118ee)


   PLDS3.DLL + 0x186a (0x0041186a)


   PLDS3.DLL + 0x1af8 (0x00411af8)


   KERNEL32.DLL + 0x3663 (0xbff73663)


   KERNEL32.DLL + 0x228e0 (0xbff928e0)


   0x00788c40
(Reporter)

Updated

20 years ago
Target Milestone: M7
(Reporter)

Comment 1

20 years ago
Putting on M7 radar.
(Reporter)

Updated

20 years ago
Summary: Crash on launch Apprunner M6 build → Crash on launch Apprunner M6 build - RAPTORHTML.DLL
(Reporter)

Comment 2

20 years ago
*** Bug 7356 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

20 years ago
QA Contact: leger → beppe

Updated

20 years ago
Assignee: rickg → jevering

Comment 3

20 years ago
JIm -- I'll give this to you since you own apprunner. But the issue is simply a
crash on startup, and we're both aware of it.
(Reporter)

Comment 4

20 years ago
Could window size have anything to do with this?  See:
http://bugzilla.mozilla.org/show_bug.cgi?id=7712

Comment 5

20 years ago
*** Bug 7712 has been marked as a duplicate of this bug. ***

Comment 6

20 years ago
shiva and ester maybe getting real close to having a good stack trace...
MTBF could go up by as much as 10x from M6 to M7 if we can fix this problem.

Comment 7

20 years ago
Esther reproduce the re-launch crash and following is the stack trace for that
crash.

 Call Stack:    (Signature = nsHTMLReflowState::ComputeContainingBlockRectangle
ae968a8c)
nsHTMLReflowState::ComputeContainingBlockRectangle
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLReflowState.cpp, line
693]
nsHTMLReflowState::InitConstraints
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLReflowState.cpp, line
769]
nsHTMLReflowState::Init
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLReflowState.cpp, line
146]
nsHTMLReflowState::nsHTMLReflowState
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLReflowState.cpp, line
129]
ViewportFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 433]
PresShell::InitialReflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 889]
XULDocumentImpl::StartLayout
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 3931]
XULDocumentImpl::EndLoad
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 1831]
CWellFormedDTD::DidBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsWellFormedDTD.cpp, line 309]
nsParser::DidBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 512]
nsParser::ResumeParse
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 867]
nsParser::EnableParser
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 587]
CSSLoaderImpl::Cleanup
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 595]
CSSLoaderImpl::SheetComplete
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 665]
CSSLoaderImpl::ParseSheet
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 697]
CSSLoaderImpl::DidLoadStyle
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 727]
DoneLoadingStyle
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 537]
nsUnicharStreamLoader::OnStopBinding
[d:\builds\seamonkey\mozilla\network\module\nsNetStreamLoader.cpp, line 158]
nsDocumentBindInfo::OnStopBinding
[d:\builds\seamonkey\mozilla\webshell\src\nsDocLoader.cpp, line 1531]
OnStopBindingProxyEvent::HandleEvent
[d:\builds\seamonkey\mozilla\network\module\nsNetThread.cpp, line 594]
StreamListenerProxyEvent::HandlePLEvent
[d:\builds\seamonkey\mozilla\network\module\nsNetThread.cpp, line 474]
PL_HandleEvent [plevent.c, line 492]
PL_ProcessPendingEvents                              [plevent.c, line 453]
_md_EventReceiverProc[plevent.c, line 872]
KERNEL32.DLL + 0x3663 (0xbff73663)
KERNEL32.DLL + 0x228e0 (0xbff928e0)
x00768c14
(Reporter)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

20 years ago
Moved into to the overall Crash on StartUp Bug:
http://bugzilla.mozilla.org/show_bug.cgi?id=7802

*** This bug has been marked as a duplicate of 7802 ***
(Reporter)

Comment 9

20 years ago
Moving all Apprunner bugs past and present to Other component temporarily whilst
don and I set correct component.  Apprunner component will be deleted/retired
shortly.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.