Double tapping on the testcase, causes page to scroll to beginning

RESOLVED DUPLICATE of bug 761721

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 761721
6 years ago
6 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

({testcase, uiwanted})

Trunk
ARM
Android
testcase, uiwanted
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 -)

Details

(URL)

(Reporter)

Description

6 years ago
Steps to reproduce:
- Go to http://people.mozilla.org/~mwargers/tests/layout/xj.htm
- Scroll to the bottom
- Pinch zoom in somewhat
- Double tap on the text

Expected result:
- Zooming out, scroll position retained

Actual result:
- Zooming out, page scrolls back to the beginning

Tested on the Samsung Galaxy Nexus.
Similar thing happens on http://people.mozilla.com/~nhirata/html_tp/xj.htm (made a page with just a bunch of "X J ... <br>" within the body of the html page.

It's not the java script or styling.
blocking-fennec1.0: --- → ?
Giving this to Finkle to find an owner.
Assignee: nobody → mark.finkle
blocking-fennec1.0: ? → +
Giving to Wes to investigate. I must have dozed off during triage or I would have pushed for soft or '-'
Assignee: mark.finkle → wjohnston
We don't attempt to retain scroll position when returning. Do we want to?

The issue I thought this was originally about is, if you double tap on a display: block element that's taller than the viewport we will zoom to the top of it. Even if you're at the very bottom of the page and the bottom of the element, we'll zoom to its top. I think that might not be what the users want. Fortunately, there aren't really any sites setup like that (i.e. people use paragraphs), and I don't think THAT should block. 

If we want to restore scroll position when zooming back out... that's a different bug. With its own set of caveats I'm sure (what do we do if you're partially zoomed and then zoom in and then zoom out. What if you zoom in and then pan around some. etc?) We need UX for that I think.
Duplicate of this bug: 743622
Ian, can you define the behavior you want for this situation?
Assignee: wjohnston → ibarlow
Keywords: uiwanted
Ideally this page should maintain it's scroll position. 

It's a little difficult to comment on how important I think this is though, since neither Wes nor I know of any "real" websites that actually exhibit this behaviour...
To clarify, I'm not convinced this is a blocker-level bug.
re-nomming to boot this bug off the blocker list
blocking-fennec1.0: + → ?
blocking-fennec1.0: ? → -

Comment 10

6 years ago
(In reply to Ian Barlow (:ibarlow) from comment #7)
> Ideally this page should maintain it's scroll position. 
> 
> It's a little difficult to comment on how important I think this is though,
> since neither Wes nor I know of any "real" websites that actually exhibit
> this behaviour...


Go to http://www.bbc.co.uk/news/technology-17935684

Scroll down a bit and double tap on the text on the left to zoom in.
Then scroll to the right and double tap on the white (empty space).
The page will then (a) zoom out and (b) scroll to the top of the page.

Is this expected behaviour?
No, it isn't. 

The page should maintain its scroll position, but this feels like enough of an edge case where it should not release block.
Assignee: ibarlow → nobody
(Reporter)

Updated

6 years ago
Blocks: 765703
My patches on bug 761721 seem to fix this issue as well; marking as a dependency.
Depends on: 761721

Comment 13

6 years ago
(In reply to Kartikaya Gupta (:kats) from comment #12)
> My patches on bug 761721 seem to fix this issue as well; marking as a
> dependency.

That's landed now, can we just close this out?
Yup
Status: NEW → RESOLVED
Last Resolved: 6 years ago
No longer depends on: 761721
Resolution: --- → DUPLICATE
Duplicate of bug: 761721
You need to log in before you can comment on or make changes to this bug.