bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.



17 years ago
17 years ago


(Reporter: James Green, Assigned: Stuart Parmenter)


({crash, hang, regression})

crash, hang, regression

Firefox Tracking Flags

(Not tracked)





17 years ago
Mozilla hangs while loading the above URL.

http://sourceforge.net/ works fine.

Other sourceforge projects pages also work fine. Just appears to be the zapping
one that causes trouble. I'm kicking off a debug build now to catch this if I
can; but please assume I'll be unsuccessful and trace the problem yourself.

Comment 1

17 years ago
Keywords: hang, mozilla0.9, regression

Comment 2

17 years ago
Turning off Javascript fixes this. Changing component.
Component: Browser-General → Javascript Engine

Comment 3

17 years ago
Assignee: asa → rogerl
QA Contact: doronr → pschwartau

Comment 4

17 years ago
Confirming with Linux nightly binary 2001-03-30-08. Mozilla actually 
CRASHED on me while loading this site. Adding crash keyword. Could not 
reproduce with a WinNT binary from the same date. 

This is unlikely to be a bug in JS Engine. I do not have a debug build
from today, and I am going on vacation for one week. If anyone is able
to attach a stack trace to this bug, please do! 

Another point: since content at this site is dynamically written, 
the problem may not always occur. It may depend on what type of content
is being written to the ad banner at the top of the page. 

As I look at the hang/crash reported in these bugs against sourceforge 
sites, I feel this bug is a duplicate:

            bug 71694  "Browser very slow (almost freezes)"
            bug 64188  "Page takes a long time to display."

Changing component to ImageLib to match those bugs -
Assignee: rogerl → pavlov
Component: Javascript Engine → ImageLib
Keywords: crash
QA Contact: pschwartau → tpreston

Comment 5

17 years ago
I can reproduce this 90% of the time in an opt build from today's tip.

I cannot reproduce at all in a debug build from today's tip (same code as
above). Even after many shift-reloads.

I have gdkpixbuf installed and compile myself.

Comment 6

17 years ago
This bug appears to have been fixed by the new imagelib
Verified no hang in Linux 2001040305
Verified no hand in W2k 2001040304
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 7

17 years ago
Verified fixed w2k build 2001081003 and linux build 2001081008
You need to log in before you can comment on or make changes to this bug.