Closed Bug 741504 Opened 8 years ago Closed 8 years ago

crash in gfxFcFontEntry::gfxFcFontEntry @ nsAString_internal::Assign

Categories

(Core :: Graphics, defect, critical)

13 Branch
All
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 739858
Tracking Status
firefox13 - ---
firefox14 - ---

People

(Reporter: rcampbell, Unassigned)

References

Details

(Keywords: crash, reproducible)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-aae1db35-057d-4e07-aa06-4f19c2120402 .
============================================================= 

Occurred when clicking on this site:
http://www.learnaholic.me/2012/04/01/the-dark-theme-for-chrome-dev-tools/

  Application Basics

        Name
        Firefox

        Version
        13.0a2

        User Agent
        Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20120402 Firefox/13.0a2

        Profile Directory

          Open Directory

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

        Crash Reports

          about:crashes

        Memory Use

          about:memory

  Extensions

        Name

        Version

        Enabled

        ID

        Adblock Plus
        2.0.3
        true
        {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

        Collusion
        0.16.2
        true
        jid1-F9UJ2thwoAm5gQ@jetpack

        CSS Usage
        0.2.9
        true
        csscoverage@spaghetticoder.org

        Firebug
        1.9.1
        true
        firebug@software.joehewitt.com

        Fire.fm
        1.4.14
        true
        {6F0976E6-26F3-4AFE-BBEC-9E99E27E4DF3}

        Firepicker
        1.4.0
        true
        firepicker@thedarkone

        FireRainbow
        1.5
        true
        firerainbow@hildebrand.cz

        Font Finder
        1.0
        true
        fontfinder@bendodson.com

        FoxGuide
        1.4
        true
        {66B2CEAE-80B4-46b0-8E4D-586721E5C1FA}

        Hide Facebook News Ticker
        0.1.1
        true
        jid1-pERypTtw9ZcTKg@jetpack

        JS Deminifier
        1.0.7
        true
        jsdeminifier@murphy.ben.name

        JSONView
        0.7
        true
        jsonview@brh.numbera.com

        Menu Editor
        1.2.7
        true
        {EDA7B1D7-F793-4e03-B074-E6F303317FB0}

        Pixlr Grabber
        2.1.1
        true
        {d47a9f51-8281-43fa-f450-f28ef8735e9a}

        RESTClient
        1.3.4
        true
        {ad0d925d-88f8-47f1-85ea-8463569e756e}

        Web Developer
        1.1.9
        true
        {c45c406e-ab73-11d8-be73-000a95be3b12}

        WebMail Notifier
        2.9.4
        true
        {37fa1426-b82d-11db-8314-0800200c9a66}

        YSlow
        3.1.0
        true
        yslow@yahoo-inc.com

        Firefinder for Firebug
        1.2.2
        false
        firefinder@robertnyman.com

        FireFTP
        2.0.1
        false
        {a7c6cf7f-112c-4500-a7ea-39801a327e5f}

        FireQuery
        1.1
        false
        firequery@binaryage.com

        Ghostery
        2.7.2
        false
        firefox@ghostery.com

        Test Pilot
        1.2.1
        false
        testpilot@labs.mozilla.com

        User Agent Switcher
        0.7.3
        false
        {e968fc70-8f95-4ab9-9e79-304de2a71ee1}

  Important Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.cache.disk.capacity
        1048576

        browser.cache.disk.smart_size.first_run
        false

        browser.cache.disk.smart_size_cached_value
        583680

        browser.places.smartBookmarksVersion
        3

        browser.startup.homepage
        https://developer.mozilla.org/en-US/

        browser.startup.homepage_override.buildID
        20120402042010

        browser.startup.homepage_override.mstone
        13.0a2

        extensions.lastAppVersion
        13.0a2

        font.minimum-size.x-western
        10

        gfx.blacklist.suggested-driver-version
        <Anything with EXT_texture_from_pixmap support>

        keyword.URL
        https://duckduckgo.com/?q=

        network.cookie.prefsMigrated
        true

        network.image.imageBehavior
        0

        places.database.lastMaintenance
        1332810965

        places.history.expiration.transient_current_max_pages
        77659

        places.history.expiration.transient_optimal_database_size
        119531110

        print.tmp.printerfeatures.PostScript/default.can_change_colorspace
        false

        print.tmp.printerfeatures.PostScript/default.can_change_downloadfonts
        false

        print.tmp.printerfeatures.PostScript/default.can_change_jobtitle
        false

        print.tmp.printerfeatures.PostScript/default.can_change_num_copies
        true

        print.tmp.printerfeatures.PostScript/default.can_change_orientation
        true

        print.tmp.printerfeatures.PostScript/default.can_change_paper_size
        true

        print.tmp.printerfeatures.PostScript/default.can_change_plex
        false

        print.tmp.printerfeatures.PostScript/default.can_change_printincolor
        true

        print.tmp.printerfeatures.PostScript/default.can_change_resolution
        false

        print.tmp.printerfeatures.PostScript/default.can_change_spoolercommand
        true

        print.tmp.printerfeatures.PostScript/default.colorspace.0.name
        default

        print.tmp.printerfeatures.PostScript/default.colorspace.count
        1

        print.tmp.printerfeatures.PostScript/default.has_special_printerfeatures
        true

        print.tmp.printerfeatures.PostScript/default.orientation.0.name
        portrait

        print.tmp.printerfeatures.PostScript/default.orientation.1.name
        landscape

        print.tmp.printerfeatures.PostScript/default.orientation.count
        2

        print.tmp.printerfeatures.PostScript/default.paper.0.height_mm
        210

        print.tmp.printerfeatures.PostScript/default.paper.0.is_inch
        false

        print.tmp.printerfeatures.PostScript/default.paper.0.name
        A5

        print.tmp.printerfeatures.PostScript/default.paper.0.width_mm
        148

        print.tmp.printerfeatures.PostScript/default.paper.1.height_mm
        297

        print.tmp.printerfeatures.PostScript/default.paper.1.is_inch
        false

        print.tmp.printerfeatures.PostScript/default.paper.1.name
        A4

        print.tmp.printerfeatures.PostScript/default.paper.1.width_mm
        210

        print.tmp.printerfeatures.PostScript/default.paper.2.height_mm
        420

        print.tmp.printerfeatures.PostScript/default.paper.2.is_inch
        false

        print.tmp.printerfeatures.PostScript/default.paper.2.name
        A3

        print.tmp.printerfeatures.PostScript/default.paper.2.width_mm
        297

        print.tmp.printerfeatures.PostScript/default.paper.3.height_mm
        279

        print.tmp.printerfeatures.PostScript/default.paper.3.is_inch
        true

        print.tmp.printerfeatures.PostScript/default.paper.3.name
        Letter

        print.tmp.printerfeatures.PostScript/default.paper.3.width_mm
        215

        print.tmp.printerfeatures.PostScript/default.paper.4.height_mm
        355

        print.tmp.printerfeatures.PostScript/default.paper.4.is_inch
        true

        print.tmp.printerfeatures.PostScript/default.paper.4.name
        Legal

        print.tmp.printerfeatures.PostScript/default.paper.4.width_mm
        215

        print.tmp.printerfeatures.PostScript/default.paper.5.height_mm
        431

        print.tmp.printerfeatures.PostScript/default.paper.5.is_inch
        true

        print.tmp.printerfeatures.PostScript/default.paper.5.name
        Tabloid

        print.tmp.printerfeatures.PostScript/default.paper.5.width_mm
        279

        print.tmp.printerfeatures.PostScript/default.paper.6.height_mm
        254

        print.tmp.printerfeatures.PostScript/default.paper.6.is_inch
        true

        print.tmp.printerfeatures.PostScript/default.paper.6.name
        Executive

        print.tmp.printerfeatures.PostScript/default.paper.6.width_mm
        190

        print.tmp.printerfeatures.PostScript/default.paper.count
        7

        print.tmp.printerfeatures.PostScript/default.plex.0.name
        default

        print.tmp.printerfeatures.PostScript/default.plex.count
        1

        print.tmp.printerfeatures.PostScript/default.resolution.0.name
        default

        print.tmp.printerfeatures.PostScript/default.resolution.count
        1

        print.tmp.printerfeatures.PostScript/default.supports_colorspace_change
        false

        print.tmp.printerfeatures.PostScript/default.supports_downloadfonts_change
        false

        print.tmp.printerfeatures.PostScript/default.supports_jobtitle_change
        false

        print.tmp.printerfeatures.PostScript/default.supports_orientation_change
        true

        print.tmp.printerfeatures.PostScript/default.supports_paper_size_change
        true

        print.tmp.printerfeatures.PostScript/default.supports_plex_change
        false

        print.tmp.printerfeatures.PostScript/default.supports_printincolor_change
        true

        print.tmp.printerfeatures.PostScript/default.supports_resolution_change
        false

        print.tmp.printerfeatures.PostScript/default.supports_spoolercommand_change
        true

        privacy.cpd.sessions
        false

        privacy.donottrackheader.enabled
        true

        privacy.sanitize.migrateFx3Prefs
        true

        security.warn_viewing_mixed
        false

  Graphics

        Adapter Description
        NVIDIA Corporation -- GeForce 6150SE nForce 430/PCI/SSE2/3DNOW!

        Vendor ID
        NVIDIA Corporation

        Device ID
        GeForce 6150SE nForce 430/PCI/SSE2/3DNOW!

        Driver Version
        2.1.2 NVIDIA 290.10

        WebGL Renderer
        NVIDIA Corporation -- GeForce 6150SE nForce 430/PCI/SSE2/3DNOW! -- 2.1.2 NVIDIA 290.10

        GPU Accelerated Windows
        0

        AzureBackend
        skia

  JavaScript

        Incremental GC
        1

  Library Versions

        Expected minimum version

        Version in use

        NSPR
        4.9
        4.9

        NSS
        3.13.3.0 Basic ECC
        3.13.3.0 Basic ECC

        NSS Util
        3.13.3.0
        3.13.3.0

        NSS SSL
        3.13.3.0 Basic ECC
        3.13.3.0 Basic ECC

        NSS S/MIME
        3.13.3.0 Basic ECC
        3.13.3.0 Basic ECC
Forgot to add that I'm on Aurora 13.0a2 (2012-04-02)
Version: unspecified → 13 Branch
appears to be caused by one of the addons. Waiting for a bisect.
Does it happen in Safe Mode (see https://support.mozilla.org/kb/Safe%20Mode)?
Component: General → Graphics
OS: All → Linux
Product: Firefox → Core
QA Contact: general → thebes
Summary: crash in nsAString_internal::Assign → crash in gfxFcFontEntry::gfxFcFontEntry @ nsAString_internal::Assign
This looks like it could be a dupe of bug 739858.
Duplicate of this bug: 757108
bug 757108 has STR.
Keywords: reproducible
Is this reproducible on trunk (Nightly, mozilla-15)? As noted in comment 5, I suspect it may be a dupe of bug 739858, which was fixed for FF15 last month.
The issue occurs also on the -prefix-free homepage:
http://leaverou.github.com/prefixfree/
I could reproduce it in Firefox 13, 14 (it doesn't happen always, though), but not in Fx 15. So it's probably fixed in trunk.

Shouldn't it be backported to Fx 13 & 14, though? It's a big stability issue IMHO...
Marking as a duplicate of 739858, on the basis of comment #9. I'll nominate the patches there for uplift to Aurora. I'm not sure this is widespread enough to merit Beta uplift, but if you think it's that serious, nominate the first patch in bug 739858 and make the case there.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 739858
You need to log in before you can comment on or make changes to this bug.