Closed Bug 741530 Opened 8 years ago Closed 8 years ago

Standalone images on dark background hides error message

Categories

(Core :: Layout, defect)

11 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 712347

People

(Reporter: j.amend, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

View a corrupt image from the address bar
Example: browse to data:image/png;base64,abc123


Actual results:

The expected error "The image [image] cannot be displayed, because it contains errors." is shown, but it is nearly black on black and so not very readable.


Expected results:

There should be some contrast for the error message text.
Reproduced:
Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0

WFM:
Mozilla/5.0 (X11; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0
Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120402 Firefox/13.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20120402 Firefox/14.0a1
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Component: Untriaged → Layout
OS: Mac OS X → All
Product: Firefox → Core
QA Contact: untriaged → layout
Hardware: x86 → All
Resolution: --- → DUPLICATE
Duplicate of bug: 712347
You need to log in before you can comment on or make changes to this bug.