Brief flash of complete page checkerboarding at top and bottom of cnn.com when overscrolling

RESOLVED WORKSFORME

Status

()

defect
P1
normal
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: cjones, Assigned: joe)

Tracking

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 +)

Details

(Whiteboard: [gfx])

Testing on a Nexus S with gingerbread.

STR
 (1) Load http://nytimes.com
 (2) Focus top-middle article
 (3) Pan quickly up until page travels past boundary, starts to spring back

There's a flash of black for a frame or so when the page springs back.  I don't see this on my sgs2, but that's not too helpful.

I also see this bug on other sites.
blocking-fennec1.0: --- → ?
Does the entire screen flash black, or it is just a portion of it?
All the gecko-drawn content.
I have seen checkboard-flashes which may be the same problem.
I'm going on the assumption that this is the complete page being checkerboarded, since Jeff says that he's seen checkerboard flashes.
Summary: Brief flash of black when panning (on PowerVR SGX540, GB) → Brief flash of complete page checkerboarding
Assignee: nobody → joe
I managed to see this earlier today - checkerboard was working fine and the correct colour, but there was a brief frame of the content area being entirely black. This seemed to happen when I flung into overscroll at the top of the page, but that may have been entirely coincidental. Certainly, it's not easy to reproduce.

I did this on an HTC Flyer running gingerbread.
blocking-fennec1.0: ? → +
blocking-fennec1.0: + → beta+
Sometimes Fennec loses its mind, forgets how big CNN.com is, and lets you fling overscroll at the top or bottom of the page to way past where the page actually ends. Fennec then figures out what's going on and scrolls you back to the right spot.

Don't know precisely what is going on in those cases, nor do I have reliable STR, but I'm trying.
Summary: Brief flash of complete page checkerboarding → Brief flash of complete page checkerboarding at top and bottom of cnn.com when overscrolling
(In reply to Joe Drew (:JOEDREW!) from comment #6)
> Sometimes Fennec loses its mind, forgets how big CNN.com is, and lets you
> fling overscroll
so is this a clamping bug?
I believe it's a state machine bug, but I'm not sure. Still investigating.
Whiteboard: [gfx]
Priority: -- → P1
This happens sometimes, when flinging from the bottom of a page to the top. While I think this should be fixed sooner than later, I don't think it needs to block beta. Hence, I'm renominating it.
blocking-fennec1.0: beta+ → ?
QA: Some reliable STR would be great on this.
blocking-fennec1.0: ? → +
qawanted: assigning to Tony, i have a nexus S to try this on
04-17-2012 nightly build, nexus S, android 2.3.3.

video screencast of checkerboarding while flinging content on a few sites (nytimes, cnn).   It looks better with the solid background to the web content, but still see it happening.   That said, i agree with Joe that it shouldn't block beta.

http://www.youtube.com/watch?v=Kf7ixC4JeuQ
Keywords: qawanted
Not really sure how to approach this bug any more.

The second page in the video is still loading so we are getting checkboarding for unloaded content.  The first page does checkboard for long periods, but I think that is not really the case in current builds.

Tony, still see such long delays?  (esp. with gfx.displayport.strategy_vb.multiplier == 2000 )

Chris, do you think this general problem still exists or do we have more specific smaller problems?
Keywords: qawanted
QA isn't seeing this in our testing as of (04/30). We just tested this in our triage. Any checker-boarding we see is the low-res caching, but nothing odd.

Recommended WFM if Tony can't reproduce.
(In reply to Aaron Train [:aaronmt] from comment #14)
> QA isn't seeing this in our testing as of (04/30). We just tested this in
> our triage. Any checker-boarding we see is the low-res caching, but nothing
> odd.
> 
> Recommended WFM if Tony can't reproduce.

I'm back in horrible MV office wifi, so loading up sites is slowing me down.  Will get back to this once i track down a working sim card.
(In reply to Aaron Train [:aaronmt] from comment #14)
> QA isn't seeing this in our testing as of (04/30). We just tested this in
> our triage. Any checker-boarding we see is the low-res caching, but nothing
> odd.
> 
> Recommended WFM if Tony can't reproduce.

Confirmed WFM on latest-aurora on 4/30, Nexu S.  no more checkerboarding on flinging of cnn.com.   Resolving.
Status: NEW → RESOLVED
Closed: 7 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.