Class not found exception in JAVA applets with Aurora and Nightly (Affects webmin file manager)

RESOLVED FIXED

Status

()

Core
Plug-ins
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Danial Horton, Assigned: johns)

Tracking

({regression})

unspecified
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox13+ unaffected, firefox14+ unaffected, firefox15 unaffected, firefox-esr10 unaffected)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120402 Firefox/14.0a1
Build ID: 20120402031127

Steps to reproduce:

Attempted to open the Webmin file manager in Aurora and Nightly


Actual results:

The applet failed to load due to a class not found exception
This is not reproducible in 11, 12 or IE9 but consistently reproducible in Aurora and nightly


Expected results:

The class should have been found, its not like its missing.
Danial, are you willing to hunt down a regression range?  Or at least link to the page showing the problem?
(Reporter)

Comment 2

5 years ago
It occurs on all 13 aurora builds, so this would be a pretty big regression range to cover to go back through all the nightlies, and unfortunately i have a wedding coming up and am in the middle of travel preparations.

i tested 4 different clean profiles from 11 - 14 and only 13 and 14 result in classnotfoundexception when trying to load the webmin file manager, i also just reproduced it on the my sites java irc applet i'll generate a test account for mozdevs to access it from
(Reporter)

Comment 3

5 years ago
i sent login info direct to your mail boris
You can binary search on nightlies, but I can totally understand that wedding travel would be more important.  ;)

The login info doesn't help much, because I don't have a functioning Java install, unfortunately....  Are you OK with me sharing the test account info with someone else who can try to reproduce?
(Reporter)

Comment 5

5 years ago
Sure, i just didn't want to post it publicly because we already have spammers scraping sites for login data xD
(Reporter)

Comment 6

5 years ago
oddly enough it does not affect all java applets.
(Reporter)

Comment 7

5 years ago
i have tested a fresh webmin install on another domain and can still reproduce it, so its something specific to the way webmin and the pjirc applet work.
(Reporter)

Comment 8

5 years ago
tested a demo pjirc elsewhere and it works :\

in that case it might be a difference between how the applet is created on php and html.
(Reporter)

Comment 9

5 years ago
Great news, i found a demonstration case that has reassured me its not my sites server config xD

ok, navigate to http://virtualmin-demo.virtualmin.com/
username: root
password: demo

the button on the left is OK

it will first load into virtualmin, you will want to click the webmin link at the top left
Once webmin has loaded, expand the Others drop down menu and select File Manager.

From what i can gather, applets executed in a page generated by php are failing to work on Aurora and nightly, while applets embedded on standard html page work fine.
Last good nightly: 2012-02-29
First bad nightly: 2012-03-01

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=30b4f99a137c&tochan
ge=1c3b291d0830
Status: UNCONFIRMED → NEW
tracking-firefox14: --- → ?
Ever confirmed: true
Keywords: regression
Hardware: x86_64 → All
Alice: Can you narrow down this to a single changeset ?
Given that range, I'll bet money it's a regression from bug 406541.

It also means it's a problem on Aurora too; nominating for tracking for 13.

John, do you have time to take a look?
Blocks: 406541
tracking-firefox13: --- → ?
(Assignee)

Updated

5 years ago
Assignee: nobody → jschoenick
(Assignee)

Comment 13

5 years ago
This is almost certainly a regression from 406541 -- I'm already working on a variant of this issue in Bug 736965
Depends on: 736965
(Assignee)

Updated

5 years ago
Depends on: 745030
Looks like regressing bug 406541 will be backed out from FF13 shortly.
tracking-firefox13: ? → +
tracking-firefox14: ? → +
(Assignee)

Comment 15

5 years ago
The culprit was backed out of aurora so this now only affects 14+

http://hg.mozilla.org/releases/mozilla-aurora/rev/96a1b7f055c9
Status: NEW → ASSIGNED
status-firefox13: --- → unaffected
status-firefox14: --- → affected
OS: Windows 7 → All
Version: Trunk → 14 Branch
(Reporter)

Comment 16

5 years ago
Hows this going John, made any headway?
(Assignee)

Comment 17

5 years ago
Danial - 
This should be fixed when Bug 745030 lands, which should be this cycle (FF15). Either that change will be backported to FF14, or 406541 will be backed out from 14 before it hits beta.
(Assignee)

Updated

5 years ago
status-firefox-esr10: --- → unaffected
status-firefox15: --- → affected
(Reporter)

Comment 18

5 years ago
alrighty, i'll cc on the other bug so im get up to date :)

Comment 19

5 years ago
Im not trying to dirty up this bug, but here are several examples to use for tests.  The ArcTest is a good example.

http://www.oracle.com/technetwork/java/applets-139976.html
FF14 should no longer be affected, as bug 406541 was backed out of that branch. QA, please confirm.
status-firefox14: affected → unaffected
Keywords: qawanted

Comment 21

5 years ago
Yeah!

Change set: f8d3886db65a

Confirmed it works.
Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0

I can also confirm on Ubuntu 12.04, Mac OS 10.8, Windows 7 using Daniel's steps from comment 9. Tested on Firefox 14 beta 10.
Keywords: qawanted
(Assignee)

Comment 23

5 years ago
406541 has been backed out of all branches, so this regression should be no more
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-firefox15: affected → unaffected
Resolution: --- → FIXED
Version: 14 Branch → unspecified

Comment 24

5 years ago
First I must regress on my post 21.  Older applets still did not run on the FF ver 14 and earlier.  Mine did run - Im guessing at the time of builds that mine was 4/17/2010 and the applets from Oracle were earlier compilations.

===
I hate to be the messenger of bad news, but...

This does not appear fully corrected.

I just pulled the latest build: ChangeSet:  6d8456a77e57 for Firefox Ver 17.

Here are two different links for Java applets.

From Oracle Java 5 (These do not work):  I cannot determine the vintage/age of these applets or what platform they were developed.

http://www.oracle.com/technetwork/java/applets-139976.html


This is one of my own developed with Java NetBeans (this works): Compiled 4/17/2010.

http://gotnarcosis.com/brucewittmeier/technical/TruckTrailerScale.html

I am running Java(TM) Platform 11.0.0.46

If Im missing something, I apologize.

Firefox 15 July 19, 2012 Changeset: dc005f41ebdd - does not work with older Java applets

Firefox 16 July 19, 2012 Changeset: 1424be157414 - does not work with older Java applets

===

Additional info:
I looked at the source to evaluate the applet tag in the HTML and it appears the same as my own with the exception of the quote marks around the class and jar file names.

I attempted to pull the .class file for a couple of the java applets from Oracle and each time it did not find the .class file.

With the code only specifying the class and jar names, it seems they should appear in the current directory.  I tried a couple of variations of paths but still came up empty.

Ill be glad to help if I can.

Comment 25

5 years ago
more...

I just went back to Minefield Ver 4.0b8pre - the Oracle applets did not run, but mine did.

Perhaps someone needs to contact Oracle and have them fix their site.

Comment 26

5 years ago
These also work fine in 4.0b8 and FF17 current release.

http://www.anfyjava.com/anj/index.html

I have sent a message to Oracle about their applets from the above page.  I will post back if I hear from them.
(Reporter)

Comment 27

5 years ago
thats because they are implemented in html and not php
(Reporter)

Comment 28

5 years ago
John, when was that backed out?, im on a 17a build from the 18th, and its not fixed there.
(Assignee)

Comment 29

5 years ago
406541 was backed out here (with the wrong bug number it seems):
https://hg.mozilla.org/mozilla-central/rev/47f814827db6

The applet does load for me in a FF17 nightly, but took ~30 seconds to finish loading. If something is still broken here it sounds like a new/separate bug
You need to log in before you can comment on or make changes to this bug.