Incorrect selector cascading when using multiple pseudo selectors

RESOLVED DUPLICATE of bug 547952

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 547952
6 years ago
6 years ago

People

(Reporter: Steve V, Unassigned)

Tracking

({css2})

11 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 611823 [details]
default.html

User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)

Steps to reproduce:

[See attachment for full code]
I created a list and applied 2 pseudo selectors to it:
- li:first-child:before { content: ""; }
- li:before { content: "·"; margin-right: 22px; }


Actual results:

The first element does not have the margin-right applied to it.


Expected results:

The first listitem should have the margin-right. All other browsers (IE8-9, Opera, Chrome and Safari) follow this behavior.
(Reporter)

Comment 1

6 years ago
Created attachment 611824 [details]
Screenshots of how all browsers render the code
(Reporter)

Updated

6 years ago
Keywords: css2

Comment 2

6 years ago
This is bug 547952.

You can fix your issue by using margin-left or padding-right or padding-left instead.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 547952
You need to log in before you can comment on or make changes to this bug.