RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: jlin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
http://www.mozilla.org/en-US/projects/

scroll down to the "Mozilla-based applications" section, there is a link text "let us know" that goes to http://www.mozilla.org/en-US/about/contact/ which is a 404.

expected result: a contact page.

Updated

7 years ago
Duplicate of this bug: 748038

Updated

6 years ago
Duplicate of this bug: 765653
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
The projects page has been revised, and the dead link is gone.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.