Replace use of deprecated controller.menus with controller.mainMenu

VERIFIED DUPLICATE of bug 604327

Status

Mozilla QA
Mozmill Tests
VERIFIED DUPLICATE of bug 604327
6 years ago
6 years ago

People

(Reporter: davehunt, Assigned: AlexLakatos)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozmill-refactor])

(Reporter)

Description

6 years ago
controller.menus was deprecated in https://github.com/mozautomation/mozmill/commit/ba8fdcadd471a34e10b0fdbbfcba4457d64e3886 and then removed in https://github.com/mozautomation/mozmill/commit/06c437895c9ce7cc82f0b4b708801b66a96b518e

We need to replace any instances of controller.menus with controller.mainMenu in order to run tests against Mozmill 2.0.

For example:

controller.click(new elementslib.Elem(controller.menus['file-menu'].menu_close));

would be replaced with:

controller.mainMenu.click('#menu_close');
(Reporter)

Updated

6 years ago
Whiteboard: [mozmill-refactor]
Vlad, can you please assign someone to work on this? Any Mozmill-2.0 work needs to be a high priority.
(Assignee)

Comment 2

6 years ago
I'll take this.
Assignee: nobody → alex.lakatos
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 604327
(In reply to Henrik Skupin (:whimboo) from comment #3)
> 
> *** This bug has been marked as a duplicate of bug 604327 ***

Good catch, Henrik. I forgot we had that bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.