Closed Bug 742018 Opened 8 years ago Closed 2 years ago

Enable Bugzilla for Mozilla Marketplace

Categories

(bugzilla.mozilla.org :: General, enhancement)

Production
enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: Harald, Assigned: dkl)

References

Details

For dogfooding purpose, "appify" Bugzilla by adding an app manifest https://developer.mozilla.org/en/Apps/Manifest.

I selected Android platform, as further additions can make it mobile-friendly/responsive or even enable a dedicated mobile interface for basic bug management.
Severity: normal → enhancement
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 101865
This is not a duplicate. This is about making bugzilla.mozilla.org an open web application for mozilla marketplace, which at a minimum for using on desktop, requires creation of a manifest. Might want to break this up into separate bugs possibly for clarification.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
OS: Android → All
Hardware: ARM → All
Also - If bugzilla currently does not have mobile-browser support, then at minimum, let's at least go for desktop support. Here's what will needed to be done:

- Create an application manifest for bugzilla.mozilla.org
- Host the manifest on bugzilla.mozilla.org
- Submit the app to marketplace-dev.mozilla.org
- Provide an install button on this bugzilla instance to install this app as an open web application
Moving to bugzilla.mozilla.org product since you are requesting that the specific "site" become an App and not Bugzilla in general.

dkl
Assignee: ui → nobody
Status: REOPENED → ASSIGNED
Component: User Interface → Administration
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa → administration
Version: unspecified → Current
Assignee: nobody → dkl
Duplicate of this bug: 806006
Component: Administration → General
Firefox Marketplace and Firefox OS have retired. In the future, we could optimize BMO for mobile and add the standard Web App Manifest.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.