Closed Bug 742070 Opened 10 years ago Closed 10 years ago

Unable to complete app submission if default locale in the manifest is not English

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect, P2)

Tracking

(Not tracked)

RESOLVED WORKSFORME
2012-05-17

People

(Reporter: krupa.mozbugs, Assigned: ashort)

References

()

Details

For the initial developer preview, we only supported en-US and therefore suppressed bugs about other locales. See bug 730005

steps to reproduce:
1. Try to upload https://people.mozilla.org/~kraj/test-files/webapps/webapp-with-de-as-default-locale.webapp
2. Fill in all the necessary fields in Step 3 and click continue




observed behavior:
If default locale in the manifest is not set to English, user is stuck on Step 3.

For beta since we support other locales, we need to fix this.
I believe this happened. And I saw this happen. But can you reproduce this now? I cannot seem to using http://people.mozilla.org/~kraj/test-files/webapps/webapp-with-de-as-default-locale.webapp
resolving for verification
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
This is happening again at https://marketplace-dev.allizom.org/en-US/developers/submit/app/details/seavans-undersea-adventure--9

reopening
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: nobody → cvan
Priority: -- → P2
Target Milestone: --- → 6.5.2
Assignee: cvan → ashort
This does not allow developer to upload any more apps until they clear their loclaStorage.
What's going on, as far as I can tell, is that you can't submit the form if the manifest locale and your browser locale disagree. The trouble shows up in `translations.widgets.TransMulti.value_from_datadict` -- the posted data has keys like `privacy_policy_en_us` but the form is looking for `privacy_policy_de` since that's what the webapp's `default_locale` is set to.
https://github.com/mozilla/zamboni/commit/013a5028a6becd129b08fd487271bd92b0fe7603
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
krupa, once qa verifies this we should probably do a bugfix release. Thanks ashort!
This is not fixed. I am still stuck at Step 3 of submission. See https://marketplace-dev.allizom.org/en-US/developers/submit/app/details/test-webapp-7
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: 6.5.2 → 6.5.4
Blocks: 752013
No longer blocks: 735054
Target Milestone: 2012-05-10 → 2012-05-17
This works on marketplace-dev. if you're still having the problem, see if clearing localStorage makes a difference.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → WORKSFORME
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.