Closed Bug 742092 Opened 8 years ago Closed 8 years ago

Bridge the permission prompt to the content using the homescreen messaging API

Categories

(Firefox OS Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
DeveloperPhone

People

(Reporter: vingtetun, Assigned: vingtetun)

References

Details

Attachments

(1 file, 3 obsolete files)

Attached patch Patch (obsolete) — Splinter Review
No description provided.
Attachment #612008 - Flags: review?(fabrice)
Attached patch Patch v0.2 (obsolete) — Splinter Review
Sorry for all the errors in the first patch. Seems like I was trying to hit a record of bugs per line.
Attachment #612008 - Attachment is obsolete: true
Attachment #612008 - Flags: review?(fabrice)
Attachment #612019 - Flags: review?(fabrice)
Attached patch Patch v0.3 (obsolete) — Splinter Review
Attachment #612019 - Attachment is obsolete: true
Attachment #612019 - Flags: review?(fabrice)
Attachment #612027 - Flags: review?(fabrice)
Attachment #612027 - Attachment is obsolete: true
Attachment #612027 - Flags: review?(fabrice)
Attachment #612035 - Flags: review?(fabrice)
Attachment #612035 - Flags: review?(fabrice) → review+
Sorry, this push was backed out on inbound because one of the changesets caused a leak:
https://hg.mozilla.org/integration/mozilla-inbound/rev/92cc2053db2f
https://hg.mozilla.org/mozilla-central/rev/6854bda609ae
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 737432
Hey, can anyone tel me what's permission that is actually use this prompt right now? I don't think I can find a way to trigger it...
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TW) from comment #9)
> Hey, can anyone tel me what's permission that is actually use this prompt
> right now? I don't think I can find a way to trigger it...

Geolocation.
I tried to inject https://maps.google.com/ as external_apps and also open it in browser, but I don't see the code in Gaia get executed. In fact, Geolocation does not work at all..
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TW) from comment #11)
> I tried to inject https://maps.google.com/ as external_apps and also open it
> in browser, but I don't see the code in Gaia get executed. In fact,
> Geolocation does not work at all..

Well there is a regression that will be fixed by bug 771518.
You need to log in before you can comment on or make changes to this bug.