Closed Bug 742150 Opened 10 years ago Closed 10 years ago

IDLType needs a custom operator== or equivalent

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 750264

People

(Reporter: bzbarsky, Assigned: khuey)

References

(Blocks 1 open bug)

Details

The current overload resolution code has this bit when it's verifying that the arg types before the distinguishing arg are all the same for all the overloads:

   if possibleSignatures[sigIdx][1][idx].type != firstSigType:
     # Throw here

When I run that on this IDL:

    void uniform1fv(WebGLUniformLocation? location, Float32Array v);
    void uniform1fv(WebGLUniformLocation? location, float[] v); 

where the distinguishing index is 1 in our impl at the moment, it throws when idx == 0, because the the two IDLNullableTypes test != to each other.  We need a replacement for this.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 750264
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.