Last Comment Bug 742160 - Import and enable AudioUnit cubeb backend
: Import and enable AudioUnit cubeb backend
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: All Mac OS X
: -- normal (vote)
: mozilla14
Assigned To: Matthew Gregan [:kinetik]
:
: Maire Reavy [:mreavy]
Mentors:
Depends on: 778675
Blocks: cubeb 768265
  Show dependency treegraph
 
Reported: 2012-04-03 20:18 PDT by Matthew Gregan [:kinetik]
Modified: 2012-07-31 19:14 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v0 (7.48 KB, patch)
2012-04-03 20:19 PDT, Matthew Gregan [:kinetik]
cajbir.bugzilla: review+
Details | Diff | Splinter Review

Description Matthew Gregan [:kinetik] 2012-04-03 20:18:28 PDT
The original OS X cubeb backend (AudioQueue) revealed what appears to be an OS bug resulting in stream deadlocks.

This cubeb backend uses the older AudioUnit API that we already use in sydneyaudio.  This backend does not yet implement requests for higher latency via cubeb_stream_init, but this may be added in the future.
Comment 1 Matthew Gregan [:kinetik] 2012-04-03 20:19:39 PDT
Created attachment 612085 [details] [diff] [review]
patch v0
Comment 2 Matthew Gregan [:kinetik] 2012-04-15 20:05:48 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/2110c3be7d53
Comment 4 Matthew Gregan [:kinetik] 2012-06-25 17:09:59 PDT
Note: this code was not actually enabled due to a missing patch chunk.  It'll be enabled in Firefox 16 via bug 768265.

Note You need to log in before you can comment on or make changes to this bug.