Archive folder appears empty when folder view is set to favourites

RESOLVED WONTFIX

Status

Thunderbird
Folder and Message Lists
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: gyges, Unassigned)

Tracking

11 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 612191 [details]
Top: folder view=all; Bottom: folder view=favourites

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

Added archive folder to favourites, set folder view to favourites.


Actual results:

Archive folder appears empty thouhg it is not.


Expected results:

Archive folder should continue to show mails when folder view is set to favourites.
(Reporter)

Comment 1

6 years ago
I had a manually created folder called "Archiv" before. I added all mails in there to the Thunderbird archive folder by clicking "archive", then deleted the manually created folder. After that, I checked the favourites option for this folder and switched to the favourites folder view. All subfolders containing the mails disappeared (see screenshot).

Comment 2

6 years ago
(In reply to gyges from comment #1)
I can make a folder favorite and it will appear in the favorites list. I tried it with local and IMAP folders. But, is your "Archiv" folder different than local/IMAP folders?

Comment 3

6 years ago
Gyges, in both of your images the Archiv folder is empty. So what should be shown in your opinion? The favourites view probably does not show subfolders (of the folders marked favourite) if they are not marked favourite themselves.

You can see it also on the Trash (Papierkorb) folder. It has subfolders in the normal view (has the expander triangle) but those are not indicated in the Favourites view.
(Reporter)

Comment 4

6 years ago
Created attachment 612509 [details]
Archive (favourite folders view) - independent folders
(Reporter)

Comment 5

6 years ago
Created attachment 612510 [details]
Archive (all folders view) - subfolders
(Reporter)

Comment 6

6 years ago
Hi Aceman,
you're right! If I make the archive subfolders favourites themselves, they appear in favourite folders view. However, then they are no longer subfolders of the archive folder, but independent folders. When I turn back to all folders view, they appear as subfolders again. I don't know if this behaviour is intended for some reason, but at least to me it doesn't seem very intuitive.
I've added two more screenshots so you can see what I mean.
Cheers
Yeah we don't recuser on folders for favorites. WONTFIXing this one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.