Crash [@ JNI_CreateJavaVM] after a while on testcase that focuses then blurs contenteditable node

RESOLVED DUPLICATE of bug 741309

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 741309
6 years ago
6 years ago

People

(Reporter: Martijn Wargers (zombie), Unassigned)

Tracking

({testcase})

Trunk
ARM
Android
testcase
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 +)

Details

(URL)

(Reporter)

Description

6 years ago
See url testcase, when I let that run for a while on the HTC Desire HD, it crashes after 3-4 minutes or so.
This is with today's Native trunk build.

https://crash-stats.mozilla.com/report/index/bp-0ee59608-aba3-43af-98d3-56dbd2120404
0 	libdvm.so 	JNI_CreateJavaVM 	
1 	libxul.so 	_JNIEnv::CallVoidMethod 	jni.h:631
2 	libxul.so 	mozilla::AndroidLayerRendererFrame::BeginDrawing 	widget/android/AndroidJavaWrappers.cpp:786
3 	libxul.so 	nsWindow::DrawWindowUnderlay 	widget/android/nsWindow.cpp:2279
4 	libxul.so 	mozilla::layers::LayerManagerOGL::Render 	gfx/layers/opengl/LayerManagerOGL.cpp:806
5 	libxul.so 	mozilla::layers::LayerManagerOGL::EndTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:454
6 	libxul.so 	mozilla::layers::LayerManagerOGL::EndEmptyTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:427
7 	libxul.so 	mozilla::layers::CompositorParent::Composite 	gfx/layers/ipc/CompositorParent.cpp:224
8 	libxul.so 	RunnableMethod<mozilla::layers::CompositorParent, void , Tuple0>::Run 	ipc/chromium/src/base/tuple.h:383
9 	libxul.so 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:318
10 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:326
11 	libxul.so 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:426
12 	libxul.so 	base::MessagePumpDefault::Run 	ipc/chromium/src/base/message_pump_default.cc:23
13 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
14 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
15 	libxul.so 	base::Thread::ThreadMain 	ipc/chromium/src/base/thread.cc:156
16 	libxul.so 	ThreadFunc 	ipc/chromium/src/base/platform_thread_posix.cc:26
17 	libc.so 	__thread_entry 	
18 	libc.so 	pthread_create
I am able to reproduce this issue on the latest Nightly (04/04) on HTC Desire Z (2.3.3.). Could it be related to Bug 741309 ?
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 741309

Updated

6 years ago
Crash Signature: 0 libdvm.so JNI_CreateJavaVM 1 libxul.so _JNIEnv::CallVoidMethod jni.h:631 2 libxul.so mozilla::AndroidLayerRendererFrame::BeginDrawing widget/android/AndroidJavaWrappers.cpp:786 3 libxul.so nsWindow::DrawWindowUnderlay widget/androi&hellip;

Updated

6 years ago
blocking-fennec1.0: ? → +
You need to log in before you can comment on or make changes to this bug.