ci.mozilla.org: sync-android has disappeared

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: rnewman, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
It used to live here:

https://ci.mozilla.org/view/Services/job/sync-android/

Now 404s. Anyone know where it went, and how to get it back? That took a while to set up :/

Comment 1

7 years ago
https://ci.mozilla.org/manage (requires you to be logged in) displays the following warning:

The following plugins are deactivated because of cyclic dependencies, most likely you can resolve the issue by updating these to a newer version.

    config-file-provider
    maven-plugin


I'm *hoping* that the project just disappeared because the Maven plugin couldn't be loaded. Lemme see if some updated plugins are available...

Comment 2

7 years ago
I've disabled the config-file-provider and Jenkins is restarting. I /think/ this plugin is only used by a Services project which isn't too important. I'll know in a few minutes, once Jenkins has finished restarting.

Comment 3

7 years ago
The config-file-provider plugin needs to be updated to version 2.0. Attempting to do that now...

Comment 4

7 years ago
Config File Provider plugin has been updated to version 2.0. Jenkins is restarting. Hopefully things will just work once it comes back online...

Comment 5

7 years ago
It seems that Jenkins was recently upgraded. The new version has some backwards incompatible changes. However, the plugins weren't upgraded when Jenkins was. It seems that the old plugin versions aren't compatible with the new Jenkins version.

Jenkins was completely busted, so I'm upgrading all plugins in hopes that fixes things. I hope we don't run into the Git plugin compatibility foo that happened a few months back...

Comment 6

7 years ago
Crap. Triggered bug 717864 again. Will need ops help to resolve this.
Priority: -- → P2

Updated

7 years ago
Blocks: 742553

Comment 7

7 years ago
All is now well.

Root cause was someone upgraded the main Jenkins instance. Our Jenkins install is like a house of cards. While the upgrade seemed to go well for most projects, it broke sync-android. While attempting to repair sync-android by upgrading other plugins to be compatible with the new Jenkins version, I broke all of Jenkins.

The problem was rectified by clearing out *all* Jenkins plugins and installing them manually from a fresh start. A single plugin (Static Analysis Collector) was causing issues when installed with a few others. This was just an aggregating plugin and was only used by sync-android. I left it out of the upgrade and all plugins are now working together without error and are running the most recent version. Yippee!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.