The default bug view has changed. See this FAQ.

Read Only Disabled When Calendar Is Cached

RESOLVED FIXED in 1.9.1

Status

Calendar
General
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: asai, Assigned: mmecca)

Tracking

(Blocks: 1 bug)

Lightning 1.3
1.9.1

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129021758

Steps to reproduce:

Create new CalDAV calendar, check Cache and Read-Only


Actual results:

Upon restarting TB, Read-Only is unchecked.  Upon unchecking Cache checking Read-Only, Read-Only stays on.


Expected results:

Read-Only should stay checked.
(Reporter)

Updated

5 years ago
OS: All → Windows 7
Hardware: All → x86_64

Updated

5 years ago
Duplicate of this bug: 772041

Comment 2

5 years ago
Confirming. Have the exact same issue. For me it only appeared in Lightning 1.5, just like described in bug 772041.

I am on Arch Linux x64, so it would be great if someone could change this bug back to "OS: All"

Comment 3

5 years ago
I can also confirm this bug on Ubuntu 12.04 amd64 with Thunderbird 15 and Lightning 1.7

Updated

5 years ago
Duplicate of this bug: 700004

Updated

5 years ago
Blocks: 462277
Status: UNCONFIRMED → NEW
Component: Lightning Only → General
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All

Comment 5

5 years ago
Bug confirmed on Win7 and Lightning 1.8

Updated

5 years ago
Duplicate of this bug: 799182
(Assignee)

Updated

4 years ago
Assignee: nobody → matthew.mecca
Status: NEW → ASSIGNED
(Assignee)

Comment 7

4 years ago
Created attachment 682810 [details] [diff] [review]
Fix v1

The read-only property is being set to false after reading the offline properties from the cache (also the disabled property, but I don't think this will work anyway without using setProperty).

Mohit, is there any reason this shouldn't be removed?
Attachment #682810 - Flags: review?(philipp)
Attachment #682810 - Flags: feedback?(mohit.kanwal)
Attachment #682810 - Flags: review?(philipp) → review+
(Assignee)

Comment 8

4 years ago
Pushed to comm-central - https://hg.mozilla.org/comm-central/rev/62ed8249ff31
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2
Comment on attachment 682810 [details] [diff] [review]
Fix v1

Review of attachment 682810 [details] [diff] [review]:
-----------------------------------------------------------------

This should be good to go. If I remember correctly this was done to prevent the offline cache getting rewritten and thus raising of the mItemInfoCache[aItem.id] not found error. I guess we can safely remove this.
Attachment #682810 - Flags: feedback?(mohit.kanwal) → feedback+

Comment 10

4 years ago
Could it be backported? It is a trivial fix without any risk from what I see. Right now, I'm being shown the invitations addressed to all my colleagues instead of just mine. If I disable caching and enable read only for other calendars, pending invitations only display the one addressed to my calendar as intended.
Comment on attachment 682810 [details] [diff] [review]
Fix v1

Matt, I'll leave the decision to you if you want this in 1.9.x ?
Attachment #682810 - Flags: approval-calendar-release?(matthew.mecca)
Attachment #682810 - Flags: approval-calendar-beta?(matthew.mecca)
Attachment #682810 - Flags: approval-calendar-aurora?(matthew.mecca)
(Assignee)

Updated

4 years ago
Attachment #682810 - Flags: approval-calendar-release?(matthew.mecca)
Attachment #682810 - Flags: approval-calendar-release+
Attachment #682810 - Flags: approval-calendar-beta?(matthew.mecca)
Attachment #682810 - Flags: approval-calendar-beta+
Attachment #682810 - Flags: approval-calendar-aurora?(matthew.mecca)
Attachment #682810 - Flags: approval-calendar-aurora+
(Assignee)

Updated

4 years ago
Whiteboard: [wanted-1.9.x]
(Assignee)

Comment 12

4 years ago
comm-beta - https://hg.mozilla.org/releases/comm-beta/rev/ac39f4b5e365
Target Milestone: 2.2 → 2.1
(Assignee)

Comment 13

4 years ago
comm-esr17 - https://hg.mozilla.org/releases/comm-esr17/rev/7c6897b7efac
Target Milestone: 2.1 → 1.9.1
(Assignee)

Updated

4 years ago
Whiteboard: [wanted-1.9.x]
You need to log in before you can comment on or make changes to this bug.