Last Comment Bug 742561 - IonMonkey: Inline allocation for JSOP_NEWOBJECT.
: IonMonkey: Inline allocation for JSOP_NEWOBJECT.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Sean Stangl [:sstangl]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: IonSpeed
  Show dependency treegraph
 
Reported: 2012-04-04 15:27 PDT by Sean Stangl [:sstangl]
Modified: 2012-04-04 21:12 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Inline allocation for JSOP_NEWOBJECT. (4.06 KB, patch)
2012-04-04 17:02 PDT, Sean Stangl [:sstangl]
dvander: review+
Details | Diff | Splinter Review

Description Sean Stangl [:sstangl] 2012-04-04 15:27:24 PDT
JSOP_NEWOBJECT should use the MacroAssembler's getNewObject() path where possible. In terms of benchmarks, this only affects v8-splay, which hits the LNewObject callVM() path 508,999 times.
Comment 1 Sean Stangl [:sstangl] 2012-04-04 17:02:18 PDT
Created attachment 612403 [details] [diff] [review]
Inline allocation for JSOP_NEWOBJECT.

Easy, since all the existing machinery can be reused.
Makes v8-splay ~25% faster locally on x86. (125ms -> 95ms.)
Comment 2 Sean Stangl [:sstangl] 2012-04-04 21:12:53 PDT
https://hg.mozilla.org/projects/ionmonkey/rev/f798ae7a24ce

Note You need to log in before you can comment on or make changes to this bug.