Content script AJAX fails with 'No Transport' in Nightly

RESOLVED DUPLICATE of bug 741390

Status

--
major
RESOLVED DUPLICATE of bug 741390
7 years ago
6 years ago

People

(Reporter: cutler.jeremy, Assigned: ochameau)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
I'm not sure if this should be opened against the Add-On SDK or Firefox.

Here's a basic run-down of the issue:

1. Add-on injects content script
2. Content script attempts AJAX GET (using jQuery)
3. AJAX always fails with "No Transport" error

The problem does not occur with the current release version of Firefox, or the Beta version. I haven't checked if the problem happens with Aurora.
Can you provide an addon that triggers this? Maybe one hosted on builder.addons.mozilla.org?
(Reporter)

Comment 2

7 years ago
I can give you my add-on, but there's a bit of setup.

Add-on: https://addons.mozilla.org/en-US/firefox/addon/missing-e/

After installing:
1) open the settings page (this happens automatically when you first install, or if you click the 'e' icon in the add-on bar)
2) Click the tab "Dashboard Features"
3) Part way down the page, in a section with the title "Sidebar Tweaks", activate the option labelled "Add blog sidebar to all dashboard pages"
4) Log in to Tumblr with this dummy account:

email: sveiki+missingetest@gmail.com
password: cleverpassword

5) Go to http://www.tumblr.com/dashboard
6) One of the content scripts will add buttons to the sidebar at the right (with buttons for Posts, Followers, Messages, etc)

On the right side of those buttons should be a number (which are loaded using an AJAX request to the same domain). Instead, little circular arrows are added (which are my add-on's notification that an AJAX error took place, clicking them will retry the AJAX call).
Could we get a reduced testcase for this? There's lots of stuff that could be going on in the full addon.
Whiteboard: [triage:followup]
(Reporter)

Comment 4

7 years ago
Created attachment 617903 [details]
Simple Add-on that exhibits bug

This is a simple add-on I threw together. It simply injects jQuery 1.7.2 and a script which injects an input box and button on http://test.missing-e.com/test.html

The injected script does an AJAX POST to http://test.missing-e.com/testpost.php and then either alerts "You said: " followed by whatever you entered into the input box or it alerts "error" and then outputs the jQuery XHR object's status and statusText fields in console output.

It works correctly when run on release versions, but on Firefox Nightly, it fails consistently with the status field is 0 and the statusText field is "No Transport".

After installing extension:

1. Go to http://test.missing-e.com/test.html
2. Type something into the input box and click the "Send" button
3. Observer error output in console
I'm having the same problem -- none of my AJAX-y content scripts work in Nightly.
This might be bug 741267 which just had a fix land on mozilla-inbound, which should hopefully make its way over to mozilla-central later today to be in tomorrow's Nightly.

Updated

7 years ago
Attachment #617903 - Attachment mime type: text/plain → application/x-xpinstall
(Reporter)

Comment 7

7 years ago
This still appears to be a problem in 15.0a1.

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Alex, can you take a look at this?
Assignee: nobody → poirot.alex
(Assignee)

Comment 9

7 years ago
Most likely going to be a duplicate of bug 741390.
As per bug 741390 comment 6, XMLHtppRequest is still broken on Nightly/Aurora.
It now depends on bug 742156.
(Assignee)

Comment 10

7 years ago
Jeremy, please do not hesitate to reopen this bug if you issue isn't solved when bug 741390 is going to be fixed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 741390
(Reporter)

Comment 11

7 years ago
I can confirm that this is now working in the latest nightly. Do you know if the fix will find its way into the Beta channel?
(Assignee)

Comment 12

7 years ago
Yes it should be fixed in beta too, bug 741267 was pushed to aurora.
Whiteboard: [triage:followup]
You need to log in before you can comment on or make changes to this bug.