Last Comment Bug 742619 - Intermittent browser_pluginnotification.js | Test 11c, Should have a click-to-play notification
: Intermittent browser_pluginnotification.js | Test 11c, Should have a click-to...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla14
Assigned To: (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
:
Mentors:
Depends on:
Blocks: 438871 711552
  Show dependency treegraph
 
Reported: 2012-04-04 21:01 PDT by Phil Ringnalda (:philor)
Modified: 2012-11-25 19:31 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Patch to disable the intermittent orange temporarily (2.19 KB, patch)
2012-04-04 22:06 PDT, (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
felipc: review+
Details | Diff | Review
Patch for bug (2.01 KB, patch)
2012-04-06 23:39 PDT, (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
felipc: review+
Details | Diff | Review

Description Phil Ringnalda (:philor) 2012-04-04 21:01:06 PDT
https://tbpl.mozilla.org/php/getParsedLog.php?id=10652228&tree=Mozilla-Inbound
Rev3 WINNT 6.1 mozilla-inbound debug test mochitest-other on 2012-04-04 17:10:54 PDT for push dfddfef84096

TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/browser_pluginnotification.js | Test 11b, Should not have a click-to-play notification
--DOMWINDOW == 89 (10F4F400) [serial = 920] [outer = 00000000] [url = about:blank]
--DOMWINDOW == 88 (10BFEDD8) [serial = 906] [outer = 00000000] [url = about:blank]
--DOMWINDOW == 87 (10BFC288) [serial = 881] [outer = 00000000] [url = about:blank]
--DOMWINDOW == 86 (10C23768) [serial = 900] [outer = 00000000] [url = javascript:1+1]
--DOMWINDOW == 85 (10F4FBE0) [serial = 918] [outer = 00000000] [url = about:blank]
--DOMWINDOW == 84 (10F501C8) [serial = 916] [outer = 00000000] [url = about:blank]
--DOMWINDOW == 83 (10BFD830) [serial = 912] [outer = 00000000] [url = about:blank]
--DOMWINDOW == 82 (10F4FFD0) [serial = 888] [outer = 00000000] [url = javascript:'foopy';]
--DOMWINDOW == 81 (10BFE9E8) [serial = 910] [outer = 00000000] [url = about:blank]
--DOMWINDOW == 80 (10BFBE98) [serial = 884] [outer = 00000000] [url = javascript:'foopy';]
--DOMWINDOW == 79 (10F4EA28) [serial = 914] [outer = 00000000] [url = about:blank]
--DOMWINDOW == 78 (10BFE400) [serial = 908] [outer = 00000000] [url = about:blank]
--DOMWINDOW == 77 (10F4E050) [serial = 679] [outer = 00000000] [url = about:blank]
--DOMWINDOW == 76 (0D1514F0) [serial = 892] [outer = 00000000] [url = data:text/html,<body>hi]
--DOMWINDOW == 75 (10BFD248) [serial = 904] [outer = 00000000] [url = about:blank]
--DOMWINDOW == 74 (0D153668) [serial = 896] [outer = 00000000] [url = data:text/html,<body>hi]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_pluginnotification.js | Test 11c, Should have a click-to-play notification
Stack trace:
    JS frame :: chrome://mochitests/content/browser/browser/base/content/test/browser_pluginnotification.js :: <TOP_LEVEL> :: line 313
    JS frame :: chrome://mochikit/content/browser-test.js :: <TOP_LEVEL> :: line 473

TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/browser_pluginnotification.js | There should be a PluginClickToPlay event for each plugin that was blocked due to the plugins.click_to_play pref
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/m-in-w32-dbg/build/netwerk/base/src/nsSimpleURI.cpp, line 293
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8729
INFO TEST-END | chrome://mochitests/content/browser/browser/base/content/test/browser_pluginnotification.js | finished in 3665ms
Comment 5 Treeherder Robot 2012-04-04 22:04:28 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=10657412&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound pgo test mochitest-other on 2012-04-04 21:18:46

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_pluginnotification.js | Test 11c, Should have a click-to-play notification
Comment 6 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2012-04-04 22:06:35 PDT
Created attachment 612454 [details] [diff] [review]
Patch to disable the intermittent orange temporarily
Comment 7 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2012-04-04 22:20:07 PDT
Temporarily disabled test 11c until a better fix for it comes around:
https://hg.mozilla.org/integration/mozilla-inbound/rev/442ae4ba8a95
Comment 8 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-05 11:28:16 PDT
http://hg.mozilla.org/mozilla-central/rev/442ae4ba8a95
Comment 9 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2012-04-06 23:39:54 PDT
Created attachment 613073 [details] [diff] [review]
Patch for bug

Sent to tryserver: https://tbpl.mozilla.org/?tree=Try&rev=6ba3a3aa21e8

m-oth is where the intermittent failures were, so I've requested a bunch of runs of m-oth on the various Windows builds to make sure that there are no more intermittent failures on this test now.
Comment 10 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2012-04-18 11:46:25 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/f2ef364eab91
Comment 11 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-19 07:20:47 PDT
https://hg.mozilla.org/mozilla-central/rev/f2ef364eab91

Note You need to log in before you can comment on or make changes to this bug.