Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Part and Quit messages get recoded however the character set is UTF-8

RESOLVED FIXED in Thunderbird 14.0

Status

Thunderbird
Instant Messaging
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Kami, Assigned: florian)

Tracking

13 Branch
Thunderbird 14.0

Thunderbird Tracking Flags

(thunderbird13 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:13.0) Gecko/20120327 Firefox/13.0a2
Build ID: 20120327115436

Steps to reproduce:

Set ÁRVÍZTŰRŐTÜKÖRFÚRÓGÉP as Part or Quit messages in IRC client


Actual results:

I got this after save and repoen:
ÁRVÍZTŰRŐTÜKÖRFÚRÓGÉP


Expected results:

I should remain as ÁRVÍZTŰRŐTÜKÖRFÚRÓGÉP
(Reporter)

Updated

5 years ago
Blocks: 740280
(Assignee)

Comment 1

5 years ago
I'm sure I've already fixed a similar issue at least once in the past, but I can reproduce this with a current trunk build! :-(
Thanks for the report! :-)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Florian Quèze from comment #1)
> I'm sure I've already fixed a similar issue at least once in the past, but I
> can reproduce this with a current trunk build! :-(
> Thanks for the report! :-)

That's why you want unit tests :-)
(Assignee)

Comment 3

5 years ago
Created attachment 613998 [details] [diff] [review]
Patch

The fix is trivial, and I think we want to take this on aurora.
Assignee: nobody → florian
Status: NEW → ASSIGNED
Attachment #613998 - Flags: review?(dbienvenu)
Attachment #613998 - Flags: approval-comm-aurora?
(Assignee)

Comment 4

5 years ago
(In reply to Ludovic Hirlimann [:Usul] from comment #2)
> (In reply to Florian Quèze from comment #1)
> > I'm sure I've already fixed a similar issue at least once in the past

It turns out it's for Instantbird that I fixed it (at https://hg.instantbird.org/instantbird/rev/69ff22bff5e3#l5.1).

> That's why you want unit tests :-)

I do want unit tests anyway :-).
OS: Linux → All
Hardware: x86_64 → All

Updated

5 years ago
Attachment #613998 - Flags: review?(dbienvenu)
Attachment #613998 - Flags: review+
Attachment #613998 - Flags: approval-comm-aurora?
Attachment #613998 - Flags: approval-comm-aurora+
(Assignee)

Comment 5

5 years ago
http://hg.mozilla.org/comm-central/rev/388c60e507d1
http://hg.mozilla.org/releases/comm-aurora/rev/9633d82db33f
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-thunderbird13: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 14.0
You need to log in before you can comment on or make changes to this bug.