install simplejson package on cb-sb-win32-tbox to fix build bustage

RESOLVED FIXED

Status

Mozilla Messaging
Release Engineering
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Stefan Sitter, Assigned: Fallen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
WINNT 5.2 comm-central lightning builds are failing for several days with the "ImportError: No module named simplejson" error noted in Bug 742375. Bug 741084 indicates it might be caused by an old Python version that doesn't contain the json or simplejson library.

Please help to update python / simplejson / build tools on cb-sb-win32-tbox. 

In my opinion it would be good if the Calendar build servers could use the same tool chain as the Thunderbird build servers that don't show the problem.
(Reporter)

Updated

6 years ago
Blocks: 742375
(Reporter)

Comment 1

6 years ago
Sorry if this is not the appropriate component for the build servers. 
Could you please point me at least to the appropriate component or person?
It is now almost two weeks since the last successful nightly build.
(Assignee)

Updated

6 years ago
Depends on: 745812
(Reporter)

Comment 2

6 years ago
To answer bug 745812 comment 4: Yes this bug and bug 742375 are currently only seen on comm-central. It might happen on comm-aurora after the next merge day if simplejson is missing on this builder too.

Bug 741084 comment 7 contains the link to the required simplejson package.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: update python / simplejson / build tools on cb-sb-win32-tbox to fix build bustage → install simplejson package on cb-sb-win32-tbox to fix build bustage
(Assignee)

Comment 3

6 years ago
Thanks for the bug link. I had the impression that they already required a newer Python/MozillaBuild which is why I was slacking a bit on this.

I've installed simplejson through easy_install on cb-sb-win32-tbox. If this doesn't fix the build, please reopen or ping me.
Assignee: nobody → philipp
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.