'Not Supported Method' error message on Air Arabia reservations page (regression since Firefox 10)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: epinal99-bugzilla2, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20120312181643

Steps to reproduce:

1) Open http://www.airarabia.com/home in a new tab
2) Book a flight, e.g. from 'Casablanca' (press 'C' key) to 'Istanbul' (press 'I' key) then click on 'Look for Flights' button
3) Select Outbound and Inbound flights (in chronological order)
4) Check 'I accept the airline's Terms and Conditions' box then click on 'Continue to Next Step' button


Actual results:

airarabia.com redirects to URL https://reservationsma.airarabia.com/ibe/public/loadContainer.action and displays a blank page with the error message 'Not Supported Method'.


Expected results:

airarabia.com should redirect to 'Enter details' webpage and not display error message.

Spoofing the UA doesn't help. It's a regression since FF10.

Regression range:
good=2011-10-07
bad=2011-10-08
m-c
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c3a50afc2243&tochange=6c780dcb4b99
m-i
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d051a5749802&tochange=fd0f0a12be74

reservationsma.airarabia.com server:
Servlet 2.4; JBoss-4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181439)/JBossWeb-2.0
(Reporter)

Updated

7 years ago
Component: Untriaged → English US
Keywords: regression
Product: Firefox → Tech Evangelism
Version: 10 Branch → unspecified
(Reporter)

Comment 1

7 years ago
More info, web console log after clicking on 'Continue to Next Step' button:

[14:46:36.950] Use of getAttributeNode() is deprecated. Use getAttribute() instead. @ http://reservationsma.airarabia.com/ibe/public/showReservation.action
[14:46:36.951] Use of attributes' nodeValue attribute is deprecated. Use value instead. @ http://reservationsma.airarabia.com/ibe/public/showReservation.action
[14:46:37.102] POST https://reservationsma.airarabia.com/ibe/public/loadContainer.action [HTTP/1.0 501 Not Supported 867ms]

Comment 2

7 years ago
Triggered by
8f011395145e	Brian Smith — Bug 669061: Upgrade to NSS 3.13 RC0, r=wtc
Blocks: 669061

Comment 3

7 years ago
Few Observations to help the developer:

1. This is happening only during http to https submit only.
2. If I remove/reduce the post content dynamically from FireBug the chances are very high to work correctly.
3. If the initial request goes via https always it works fine. (We have done this temporary in production)
4. This is happening only in Firefox 10, 11 (haven't check 12+). All other versions of FF, IE, Google Chrome works fine.
(Reporter)

Comment 4

7 years ago
Thanks for the extra info, in addition it will help to find a more generic title describing the regression (about SSL a priori).

Comment 5

7 years ago
We have observed that switching to https only will not resolve the issue and it's happening periodically. 

Any update on this issue or appreciate any workaround which any one could suggest in order to eliminate this issue.
Component: English US → Plug-ins
Product: Tech Evangelism → Core
QA Contact: untriaged → plugins
(Reporter)

Comment 6

7 years ago
(In reply to Nilindra from comment #5)
> We have observed that switching to https only will not resolve the issue and
> it's happening periodically. 
> 
> Any update on this issue or appreciate any workaround which any one could
> suggest in order to eliminate this issue.

Hi. I tried to reproduce the STR given in comment #0 and I'm not able to reproduce the issue. So is it fixed on your side? Or do you have new STR to reproduce it again?

Anyway it would be good to know if there is no regression bug hidden in the code of Firefox.
Component: Plug-ins → Security: PSM
QA Contact: plugins → psm

Comment 7

5 years ago
Sorry for the late reply. Hope this will help some one out there.

We upgraded to a new hardware load balancer which it self eliminated the issue reported. 

I believe with the old hardware load balancer there was a SSL issue for FF 10, 11 ++.
(Reporter)

Comment 8

5 years ago
ty for the feedback.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.