High CPU Usage On ReMo HP In Firefox 11 Normal Release

RESOLVED WORKSFORME

Status

Mozilla Reps
reps.mozilla.org
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: bensternthal, Assigned: pierros)

Tracking

0.3 - Sarek
x86
Mac OS X

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 612584 [details]
Shows cpu usage using activity monitor.

I noticed my mac's fan turning on when visiting the ReMo HP. Poking around I found my cpu averaging around 85-100% on this page and this page only.

I turned off firebug and did not notice a change.

I can reproduce this by quitting firefox and heading to the remo HP. Note this is the standard ff11 release not nightly or aurora.
(Reporter)

Updated

6 years ago
Assignee: nobody → pierros
Created attachment 612599 [details]
Stephen's screenshot

Yeah, I see largely the same thing when I hit the homepage with Firefox 11; upwards of 89% when the slider moves into view; nightlies are in the 70% range, though.
From my investigation, every 22 (4000/180) milliseconds, this slider triggers a change of a transform css property (+2deg). It's the rotateTimer function.

I think it got better because of bug 524925 fixed in Firefox 12.

The timer animation speed doesn't seem configurable so we should disable the timer.
http://foundation.zurb.com/docs/orbit.php

PS : Minified code in the repository does not help to debug this.
(Reporter)

Comment 3

6 years ago
Moving to 0.2.5 release
Version: 0.2 - Skon → 0.2.5 - Sasak
Status: NEW → ASSIGNED
Status: ASSIGNED → NEW
(Assignee)

Comment 4

6 years ago
Moving to 0.3 we need more data after the push of 0.2.5
Version: 0.2.5 - Sasak → 0.3 - Sarek
I can't reproduce this bug on the latest remo codebase with FFX 14 on Linux.
(Assignee)

Comment 6

6 years ago
Works for me on 16.0a1 on OSX
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.