Closed Bug 742811 Opened 8 years ago Closed 6 years ago

Move b2g-specific parts of Marionette client into separate module

Categories

(Testing :: Marionette, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 902711

People

(Reporter: jgriffin, Unassigned)

Details

Currently, B2G-specific code is intermingled with generic Marionette client code in several places.  This will make it more awkward to support non-B2G cases in the future.

To fix this, we should provide a Marionette module containing a generic client and testrunner implementation, and then provide a separate B2G module that builds on top of that.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 902711
You need to log in before you can comment on or make changes to this bug.