Hyperlinked text keeps property with new text

VERIFIED DUPLICATE of bug 99089

Status

SeaMonkey
Composer
P5
enhancement
VERIFIED DUPLICATE of bug 99089
17 years ago
13 years ago

People

(Reporter: rebron, Assigned: Charles Manske)

Tracking

Trunk
mozilla1.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rfe])

(Reporter)

Description

17 years ago
This bug is so damn annoying.  
Using Mozilla/5.0 (Windows; U; Win98; en-US; 0.8.1) Netscape6/6.5b0
2001032904

To recreate:
Open up a new composer, type in "some text", select that text and press link,
hyperlink that text to some url i.e. http://www.mozilla.org.  When you start
typing again, the next set of characters are still hyperlinked even if you do a
carriage return.  

Expected results:
After selecting text to be hyperlinked, next set of characters i.e. a space, a
carriage return, some text, should not be hyperlinked and should be plain text

Right now the workaround is to type a complete thought or paragraph and go back
and do the hyperlinking later. Lame.  Also, I believe this is a problem in
Mail/Compose.

Comment 1

17 years ago
actually, there is a menu item to do just what you want Format|Discontinue Link 
(Shift+Ctrl+L). Also, after inserting the link, you could try hitting the 'END' 
key which will get you out of the link as well.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 2

17 years ago
verified in 4/3 build.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

17 years ago
reopening.  Marking as a feature request. And marking nscatfood 'cuz I'm finnicky.
Status: VERIFIED → REOPENED
Keywords: nsCatFood
Resolution: WORKSFORME → ---
Summary: Hyperlinked text keeps property with new text → [RFE]Hyperlinked text keeps property with new text
(Reporter)

Comment 4

17 years ago
Oh and the feature request is to make the expected results specified as the
default action.  A user shouldn't have to go to the Format menu to break the
style (and they won't know to do that, I would have never figured that one out).
 Also, this bug is especially annoying when creating a list i.e.:
stuff1
stuff2
stuff3

and hyperlinking along the way (not afterwards).  

Comment 5

17 years ago
so, what is the expected behavior? You can't base it on entering a space or 
character, so, what are you expecting to have happen?

Comment 6

17 years ago
future
Severity: normal → enhancement
Priority: -- → P5
Target Milestone: --- → Future
(Reporter)

Comment 7

17 years ago
Expected behavior is:
as I'm typing and I go and hyperlink the last word I typed, the next character
(after the hyperlink dialog) should not be part of that hyperlink whether that's
a space bar or a new character like a period.  Also, when I hit the enter or
return key, I should be able to start a new non-hyperlinked line.

steps to reproduce expected behavior:
1. Start composer
2. Type Google
3. Highlight Google with cursor
4. Hit hyperlink button
5. Hyperlink to http://www.google.com
6. Press Ok
7. Next character should not be hyperlinked (whether it's a space, a character
or a carriage return).

Updated

17 years ago
Whiteboard: [new feature]

Updated

17 years ago
Summary: [RFE]Hyperlinked text keeps property with new text → Hyperlinked text keeps property with new text
Whiteboard: [new feature] → [rfe]

Comment 8

17 years ago
-->cmanske
Assignee: beppe → cmanske
Status: REOPENED → NEW
OS: other → All
Hardware: PC → All
(Assignee)

Comment 9

17 years ago
We need to do something about this!
Status: NEW → ASSIGNED
Target Milestone: Future → mozilla1.0

Comment 10

17 years ago
spam composer change
Component: Editor: Core → Editor: Composer
(Assignee)

Comment 11

17 years ago
Making the Enter/Return key terminate a link is covered by bug 99090

*** This bug has been marked as a duplicate of 99089 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 12

17 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.