Closed Bug 74300 Opened 24 years ago Closed 24 years ago

GIF transparency sometimes broken.

Categories

(Core :: Graphics: ImageLib, defect)

x86
Linux
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: tenthumbs, Assigned: saari)

References

Details

(Whiteboard: [imglib])

Attachments

(5 files)

GIF transparency is sometimes broken. Look at the attached screenshot. 
Neither the non-interlaced GIF in the lower left nor the interlaced GIF 
in the lower right display properly.

Sometimes viewing the GIF and then going back will make it display 
properly. Reloading the page makes it fail again.

It is also true that viweing a GIF and then going back to the page makes 
some if the images disappear entirely but that may be another problem.

0331 nightly build
Attached image screenshot
*** Bug 57727 has been marked as a duplicate of this bug. ***
Whiteboard: [imglib]
both of those GIF images in the screenshot are animating GIFs, arent they? If
so, this bug is a duplicate of bug 73978
No, they are just single image GIFs.
For me, the problem appears with single image GIFs as well as animated GIFs.
Something wrong with the transparency i guess. I'm using Build 2001041214 on
SuSE Linux 7.0. Didn't show up with the last nightly i used (don't remember the
build-#, but it was from late march).
Attached image Snapshot of broken look
->saari
er, for real
Assignee: pavlov → saari
think this is fixed, needs testing, adding qawanted keyword, 
Keywords: qawanted
Fixed
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → FIXED
Verified fixed linux build 2001050108, mac build 2001050104
Status: RESOLVED → VERIFIED
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: