If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Silent failure of Mozmill tests using hotfix-2.0 branch

RESOLVED FIXED

Status

Testing Graveyard
Mozmill
RESOLVED FIXED
6 years ago
a year ago

People

(Reporter: davehunt, Assigned: davehunt)

Tracking

({regression})

Details

(Whiteboard: [mozmill-2.0+])

Attachments

(2 attachments)

(Assignee)

Description

6 years ago
Steps to reproduce:

$ mkvirtualenv mozmill-2.0
$ git clone https://github.com/mozautomation/mozmill.git
$ cd mozmill
$ git checkout hotfix-2.0
$ ./setup_development.py 
$ cd ..
$ hg clone http://hg.mozilla.org/qa/mozmill-tests
$ cd mozmill-tests
$ mozmill --binary=/Applications/Firefox\ Beta.app/Contents/MacOS/firefox-bin -t tests/functional/testAddons/testManagerKeyboardShortcut.js

Actual output:
INFO | Passed: 0
INFO | Failed: 0
INFO | Skipped: 0:

Expected output:
...
INFO | Passed: 1
INFO | Failed: 0
INFO | Skipped: 0

The same test passes when using master instead of hotfix-2.0
Does it also happen on other platforms as OS X? We should do a regression test on master to find out what has been fixed the problem over there. Otherwise it should block mozmill 2.0.
Whiteboard: [mozmill-2.0?]
Keywords: regression
(Assignee)

Comment 2

6 years ago
I wasn't able to find a regression range due to tests failing before this fix: https://github.com/mozautomation/mozmill/commit/4a18584f00b18d3b750e5e2bb4ea25870f30362b. I can look into this again today.
You can use Python 2.6 which should still be installed on your OS X machine. So that mentioned issue shouldn't be an issue.
(Assignee)

Comment 4

6 years ago
A bisect on hotfix-2.0 determined that this was broken by https://github.com/mozautomation/mozmill/commit/b40e6f84b6778258dce143ecd9ad3318ccb89a05

Related bug 698872 also mentions this issue in comments 4 & 5.

I will continue to investigate.
(Assignee)

Comment 5

6 years ago
It appears that the patch for bug 695721 was not merged to hotfix-2.0, so the patch for bug 698872 specified an incorrect location for mozmill.js. I will attach a patch that corrects the location of mozmill.js and resolves this issue. The alternative would be to merge the patch from bug 695721 to hotfix-2.0.
(Assignee)

Comment 6

6 years ago
Created attachment 614017 [details] [diff] [review]
Correct location of mozmill.js. v1.0
Attachment #614017 - Flags: review?(jhammel)
(Assignee)

Comment 7

6 years ago
Created attachment 614021 [details]
Pointer to Github pull request: https://github.com/mozautomation/mozmill/pull/16

Pointer to Github pull-request

Updated

6 years ago
Whiteboard: [mozmill-2.0?] → [mozmill-2.0+]
(Assignee)

Updated

6 years ago
Attachment #614021 - Flags: review?(jhammel)

Comment 8

6 years ago
Comment on attachment 614017 [details] [diff] [review]
Correct location of mozmill.js. v1.0

Assuming this is tested and works, looks good to me
Attachment #614017 - Flags: review?(jhammel) → review+
(Assignee)

Updated

6 years ago
Attachment #614021 - Flags: review?(jhammel) → review?(hskupin)
Comment on attachment 614021 [details]
Pointer to Github pull request: https://github.com/mozautomation/mozmill/pull/16

Landed on hotfix-2.0 as:
https://github.com/mozautomation/mozmill/commit/8941331da0304b32480bfaaeef7e351978b77342
Attachment #614021 - Flags: review?(hskupin) → review+
It's a regression from bug 698872 which imported the mozmill.js file from the wrong location.
Assignee: nobody → dave.hunt
Blocks: 698872
Status: NEW → RESOLVED
Last Resolved: 6 years ago
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → FIXED
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.